[TESTING] Kodi v19 builds for Vero 4K / 4K +

The database might be corrupt.
Does it work on a fresh Kodi userdata?

How are you triggering the update of the Library?

As you log shows only enabled on startup

    <setting id="videolibrary.updateonstartup">true</setting>
    <setting id="videolibrary.backgroundupdate" default="true">false</setting>

To clarify, as Grahamh will probably have seen from my other post, I was also using 4k @ 30.

1 Like

Thanks. You will have to leave it with us - I have some ideas now. You have a workaround in the meantime - all users, especially music lovers, should make sure their GUI is 1080p resolution and those with 4k videos with 44.1k audio can force 48k fixed-rate audio.

I have no problems on my S905X Box with coreelec. There are all covers visible.

How could i create a new kodi userdata on the Vero 4k+?

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2


I’m having issues playing 4k movies specifically. No issues playing regular blu-ray files. Eventually I get it to work but its always a hassle for me. Takes a few tries. I’ve tried delaying the refresh rate but it doesn’t work. This is a projector setup. The vero4k+ connected to an oppo through its hdmi in, the oppo is connected to a denon receiver. I enabled debugging and have two different logs. The first the 4k movie actually played, however I stopped the movie and it didn’t return to kodi. Here is the log:


The second time I tried to play a 4k movie it didn’t play. Here is that log:


Any idea what is going on? Thanks!


From a quick glance I spotted a couple of things, leave it with us.


Care to share? At least this way I’ll know what to look for when there is an update.

You have this log spam:

Aug 04 19:56:21 osmc kernel: 
                             [amvideo..] saturation_post:0 hue_post:0 mab:1000000
Aug 04 19:56:21 osmc kernel: GFH video_contrast_store contrast 0 vd1_contrast 0
Aug 04 19:56:21 osmc kernel: 
                             [amvideo..] saturation_post:0 hue_post:0 mab:1000000
Aug 04 19:56:21 osmc kernel: 
                             [amvideo..] saturation_post:0 hue_post:0 mab:1000000
Aug 04 19:56:21 osmc kernel: GFH video_contrast_store contrast 0 vd1_contrast 0
Aug 04 19:56:21 osmc kernel: 

every second in your kernel log. I don’t think this is expected.

Try a re-boot. I think secureOSMC has crashed / hit a bug.


Yeah 50/50 whether a reboot works or not. As an fyi I’ve been having this type of issue for a while so I don’t think its a Matrix issue.

Does systemctl restart apploader.service help when you have a playback issue?

It’s late here (almost 5AM) but we’ll look in to the root cause properly tomorrow.


It seems to help. Problem is I’m not 100% sure because if I get a 4k movie to start and then I stop it I can’t get back to kodi. I get a blue screen from the projector. It’s something not playing nicely with the projector. It’s a JVC rs500 and it takes its sweet time between refresh rate changes

Fair enough – is it possible for you to test on a TV temporarily to eliminate this factor?

Ideally we need more logs after that command.



Log attached. I have another vero connected to a denon receiver that is connected to a tv and no such issues. Very strange behavior from the projector. I turned on the logs and restarted the vero and kodi didnt come up so i restarted media center via the command line and it came up. I tried to play a 4k movie and it failed. I ran the command you gave me and tried to play the same movie. It failed. I immediately tried a different 4k movie and it worked. I was able to replicate this behavor 3 times in a row. The same movie would fail but a different one would work immediately after. Seems like an hdmi handshake issue with the 4k movies.


Think I spoke too soon about my other vero working 100%. That one plays 4k movies and regular blu-rays fine every time. It’s having trouble with 3D movies though. Fails every time. Here is the log:


Just updated to the newest beta and now I got this :frowning:
Just a bluscree with a sad face.

Well either provide logs via grablogs -A and/or remove the user data following the instructions here

just did a clean reinstall and updated to the latest beta. now the vero is booting correctly. but my problem with the missing covers from collections still exists :frowning:

Here is the log file:


Thanks Tanio99,
Now in Blue ray ISO container which have 2d and 3d subtitles is ok , as it should be.
Works perfect !