[TESTING] Kodi v19 builds for Vero 4K / 4K +

Has anyone managed to get the Amazon VOD add-on working yet? It works fine under Matrix on my Fire Stick 4K, but it refuses to install on the Vero 4K+ because of dependency issues.

Would logs be any use here?

Unfortunately, as with most major updates to OSMC, it does not play nicely with my Marantz AVR. I had got to a very stable place with the 4.9 test build. The new update is giving me lots of issues, e.g. occasional ARC lock-outs, blank screen on booting the Vero, switching input gets it back, but on starting playback the TV switches to another HDMI input - switching back gives me the in-play video and audio, but when I stop playback, I get a 480p display. Here is a log of a sequence leading to the 480p display.

https://paste.osmc.tv/jetolinuni

I am currently having a bear of a time getting this upgrade to work. The addons are a complete mess. Even after renaming my main .kodi folder and starting from scratch, I can’t install any addon from a third party repo (in my case I’m trying to install skin.artic.horizon) that has any kind of dependency (I always get a dependency failed message), even when that dependency is in the main Kodi repo. I’ve checked all the boxes about using 3rd party repos, and if I install the actual dependency manually (when I can find it), I at least get past that error.

One last thing (and I’m saying this just for context). I am a member of Team Kodi, so I have more than a passing familiarity with what’s going on and how to troubleshoot. I definitely would like suggestions, but I’d ask that you skip the basic ones.

Kodi debug logs should show which dependencies are failing.

Do these addons install OK with a clean Kodi userdata directory?

Nothing has changed since the 4.9 update where things were working well for you. There has been a CEC update however. Did you try the suggestion of powering everything off at the mains as mentioned in the first post?

Sam

Nope. Not even with a clean Kodi directory.

OK, a Kodi debug log of that should help.

Sam

I had pulled the power to the AVR to resolve an ARC lock-out but not the TV - pulling the power to the TV seems to have fixed it! To think that a CEC update could render the system essentially unusable and lead to blanking/480p output, good to know of a simple fix.

1 Like

https://paste.osmc.tv/ifesekulez

Here’s the line to look for showing the skin install starting:

CAddonInstaller: installing 'skin.arctic.horizon' version '0.5.65' from repository 'repository.jurialmunkey'

This is starting from an absolutely empty .kodi directory. The only thing I did before enabling debug logging was install the jurialmunkey Alpha repo (where Arctic Horizon is). Then I enabled debug logging, restarted, and tried to install the skin.

I was able to get the skin installed by installing every dependency individually before installing the skin. I’m going to go back to my backup Kodi directory, remove the Addons33 (and 27) dbs and all the installed add-ons and then try doing all these installs that way. At this point I just want to get back to a usable system before tonight so that my spouse doesn’t kill me. '-)

all the problems came back first time I re-booted the Vero, had to power down everything again to get a functioning system. Subsequently I was able to get the Vero to reboot without everything going wrong, but I had to switch input away from the Vero then back, and did not see the blue OSMC screen. So for now feels a bit flaky compared to the 4.9 test build.

EDIT: shortly after the “good” re-boot, lots of issues and a 480p display on stopping playback. Another full power-down and disconnect the Vero HDMI cable got me back. So for now re-booting is a problem.

  1. I did a fresh install on my vero4k (used above image with windows installer to usb drive). First thing I did was connecting to my mysql. After the reboot it did fall back to osmc default skin (I selected kodi when installing). Now when selecting to switch skin again, the confirm dialog apprears for half a second and then falls back to osmc. If I am really fast I can confirm it, then it stays a random time between 2sek and 5min until it just reloads default again. After 15 tries it seems to stay.

  2. After I “set content” of my sources, it just does not get saved. All other settings seem to stay. The scan also never starts.

  3. All video files I tried to play (via file section) crashes the system (sad face). I’m using a NFS share.

I did a “reset Kodi on reboot”. Didn’t help.

Update: did a full reinstall. This time I configured a source as first thing (didn’t do an update this time). Could set content and could even play a file. Then did a reboot. Skin gone again. Then configured mysql, that broke both the content and playing files.

Update2: see split topic Upgrade to Kodi v19 (matrix) problems with MySQL for database fix

Hello, @sam_nazarko . So, the fact that we can now watch videos on YouTube in HDR is fabulous! But there’s one very subtle issue. (I’m not certain if it’s a problem with OSMC or with the YouTube add-on). There are a handful of videos on YouTube that are in HLG format, for example, this one: https://youtu.be/GHnwP3Taat4

If I play that video then the TV switches to HDR mode, but not to HLG HDR. (And I know the TV can handle HLG properly from the Vero because if I play the HDR test loop in iPlayer, that correctly switches the TV to HLG HDR mode).

Just a quick post to say I did a clean install of the v19 test build on my 4K+ and so far all is well. After 1st boot I copied over my mediasources, sources, advancedsettings and playlists xml files. Since all my media have Kodi-generated nfo files I scraped them using the local info scraper, it went fairly quickly.

Everything seems to be working, I’ll post again if something catastrophic happens.

Thanks for all your work!

1 Like

Still no fix for AAC it seems, shame :slightly_frowning_face:

I think I know why that is. Will investigate.

I can’t think of major changes since 4.9 test builds that would do this. Were you staying on top of 4.9 builds ie not just sending any custom changes I sent you but updating after that point?

We will get it sorted. I’m a bit shattered now. I will think of the best process of elimination. We should be able to get you on to 18.9 and then update to the latest kernel. If your issue isn’t present, then we know the issue is introduced by Kodi v19 specifically.

If there’s a timing issue, hard coding your EDID would help. HPD Lock under Settings → Display may also help

Cheers

Sam

This is still on my list of things to look in to.

Sam

Thanks for the report Kyle. I’ll try and repro and check with DaveBlake (Kodi release manager) if this is an upstream bug that is fixed in top of tree. He is using a Vero as a daily driver now, which helps.

Soon I’ll move us to 19.1 RCs.

1 Like

Just a followup to my earlier post. I was finally able to get all my add-ons reinstalled, but there does seem to be a common thread to my problems. If I install an add-on from the Kodi repo, everything is fine. It downloads and installs alll the dependencies and then installs the add-on. If I install something from another repo that has dependencies that are in the Kodi repo, it fails saying it can’t find the dependency. If I install the dependencies from the Kodi repo by hand and then install the add-on, it’s fine. The “joy” of this method is that modules can’t be installed by hand, so I had to grab copies from the repo, zip them up, install them, then find them to “update” them from the Kodi repo so that they will get updates in the future.

I really hope nobody else has this kind of problem and that it’s something strange with my setup, but I did want to report it since we’re still in testing mode.

1 Like

I have almost the same problems as you . Have to manually search for dependencies. Also for Arctic horizon for example. I have downgraded back to 18.9 with the 4.9 kernel for now. Everything super stable again now.