[TESTING] Linux 4.14 kernel for Raspberry Pi


I’m finding that the current sources in GitHub won’t build package kernel-osmc for rbp2.
The build errors out with the message:

    install -p    -o root -g root  -m  644 REPORTING-BUGS                  /mnt/package/kernel-osmc/src/linux-4.14.15/debian/rbp2-headers-4.14.15-5-osmc/usr/share/doc/rbp2-headers-4.14.15-5-osmc/
    /usr/bin/install: cannot stat 'REPORTING-BUGS': No such file or directory
    debian/ruleset/targets/headers.mk:40: recipe for target 'debian/stamp/install/rbp2-headers-4.14.15-5-osmc' failed
    make[1]: *** [debian/stamp/install/rbp2-headers-4.14.15-5-osmc] Error 1
    make[1]: Leaving directory '/mnt/package/kernel-osmc/src/linux-4.14.15'
    debian/ruleset/local.mk:102: recipe for target 'kernel_headers' failed
    make: *** [kernel_headers] Error 2
    Building kernel headers package failed
    Makefile:8: recipe for target 'rbp2' failed
    make: *** [rbp2] Error 1

It looks to be the same as the problem reported here:


Your kernel-package-osmc is too old.

Purge your toolchain.



Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.



Thanks Sam, but I don’t think the module got built? Maybe somebody else can confirm, because I cant find it.


Got the latest and the module loads perfectly and allows me to use the USB wireless NIC again. Thanks again Sam for your help!



I’m having some issues that I’ve tracked down to the IO scheduler being used in 4.14.

Whenever my raspberry pi 3 is playing music and gets a bit of IO load (i.e. apt-get update), the music stops playing for a few seconds until the IO operation finishes. The only IO scheduler I have available in 4.14 for the root filesystem is “noop”.

I’ve reverted the kernel to 4.9 where the default IO scheduler is “bfq” and I can’t repro the issue. Playback is steady no matter what other operations I run in parallel.

I see the only scheduler enabled into the kernel in 4.14 is “noop”: https://github.com/osmc/osmc/blob/master/package/kernel-osmc/patches/rbp2-000-add-kernel-config.patch#L341-L346
Is there any reason for not compiling “deadline” or “cfq” as well?

Feel free to ask for any other information that could be useful :slight_smile:


I’m afraid I’ll need to jump in here as well. Read carefully as my issue seems to be two-folded:

Ever since I’ve upgraded to 4.14, I noticed the “Under-voltage detected! (0x00050005)” in my dmesg.
I’ve disconnected all USB devices except by boot disk, and have tried multiple (three!!!) different PSUs, the issue remains. This under-voltage message has been introduced in the 4.14 kernel, and it seems people aren’t that happy with it (see https://github.com/raspberrypi/linux/issues/2512). I’m still not sure if this is an actual issue with my Pi3, or something fundamentally broken.

I’m using my rPI as both mediacenter, but also as ADSB-receiver. The reason I’ve started looking into this is because after the March 5 update my so-called “mlat client server status” is showing as “clock unstable” and therefor not able to sync with other mlat-clients. I’ve never had this, therefore suspected the 4.14 kernel. Now after manually downgrading the kernel to 4.9.29-10-osmc, the clock is stable and mlat running happily, confirming my theory.

Perhaps a long stretch, but I got a hunch this could be related to the stuttering as experienced here: Playback Video - sound stuttering after March 5th Update

Just wanted to share my experience and feedback. I’d love to help and test in order to get 4.14 running as happy as 4.9. If anything is needed, let me know.


Under Voltage means Under Voltage. So either all your three power supplies are not providing stable 5V or your connection cable is not working well

I also use a ADSB-receiver and don’t have any issues


I’ve always been a big fan of BFQ and was excited to see it mainlined for 4.14.
Ironically, it’s broken in 4.14. I’m keeping an eye on the issues and as soon as it’s stable again, I’ll re-add it as the default governor.


Sorry i just saw this topic. I have issues with 4.14 too. I have mcp2515 can module. when i want to use it send or receive messages from module with my kodi script my raspberry frozes also after send or receive event if i try to connect ssh it freezes even script is not running.

I also sent this issue to leia built topic because i tought that it was about leia built but i realise that its about kernel 4.14. so i downgrade my kernel to 4.9 it works perfect. i dont know this happens with other OS 4.14 but it happens. I dont want my kernel outdated pls help if you can. Tnx to Osmc team for this awesome job…


We would need to see a debug log


dmesg -w

only thing i can see as error is this

“can_dev: no symbol version for module_layout”
ps. without script running.

after my script runs it gives https://paste.osmc.tv/icumihoxat


any idea?


No ideas without debug logs. Blind guessing is a waste of everyone’s time…


what u mean with debug log ? i sent result with dmesg -w. if its not what u mean how can i get it?


It’s all explained in the Wiki. Why not checking there?



Hi all any progress in the IO scheduler update?? I am facing the same issue with rPi3B+ movie+torrent not working well. I have tracked for this as root cause.


Not yet unfortunately.