[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

Followed! Thanks!

I bought the Vero 4K based on the feedback in this thread as well as other mentions of it:


It isn’t a “do it all” box because it can’t handle commercial streaming services like NetFlix, Prime etc, but it CAN (eventually) do 3D-MVC, which the Shield cannot.

Of course the Pi3B OSMC and LibreELEC builds can do 3D-MVC already and those are free so…I guess I want a new gadget…:wink:

Thanks Sam. I guess I’ll figure out how to do that once I get it!

Sadly, that is the only non-proprietary option I’m aware of for 3D-MVC…:frowning:

On the plus side, my disdain for Kodi is in the interface and “player only” paradigm. It works well. The setup garbage is the part I don’t like. Stuff like setting up SAMBA shares…connecting to Windows servers…creating libraries…yuk! I like the client/server paradigm of Plex. It just isn’t and never will be capable of playing 3D-MVC. So the plus side is that with OSMC, I don’t have to really see Kodi and since I’m using the Plex for Kodi add-on I don’t have to see it at all if I don’t want to!

I was unaware of the current limits with the player because as I mentioned above, it was the best recommended player in that Kodi thread: (Kodi Media Player Options with 3D MVC & HD Audio)

  • 3D ISO’s + 3D MVC MKV’s + full HD audio bitstreaming + full 4K HDR w/Max CLL/FALL info passthrough

There isn’t anything I can do about it now. It’s ordered and I’m curious to compare the performance of such a box to say a Pi4 LibreELEC build.

I don’t know about with the Vero 4K or with subtitles. I can tell you that OSMC and Plex for Kodi add-on, on my test Pi3 last night worked great with minimal settings tinkering. I didn’t try subtitles because I don’t often use them, but I’ll try it and get back with you. The 3D-MVC playback was nice though! I couldn’t see a setting adjustment for 3D depth within OSMC, but I didn’t dig into the non-obvious options very far. I was very happy when I just hit play and my projector switched to the proper 3D mode and just worked! I tried ti with MVC and TAB formats and it worked both times! Love it!

Sure. Just note that the review in the Kodi forums thread is based on the test software release, not the standard software. See also: Vero 4K+ Mini-review: The Only Native Kodi 4K + 3D Set-top Player

In the short term, I imagine the Vero will be better. As far as I’m aware, the software still hasn’t quite caught up with the hardware on the Pi 4. Longer-term, I don’t know.

The last time I tried Plex was a long time ago, so this may have changed since then. But back then, using Plex client and server, the only way the server could deliver subtitles was by transcoding the video and burning them in, in real time. If it still has to do that, there’s a chance it won’t work with 3D subs, which are rather more complicated than 2D. And even if it does work, it puts a lot more load on the server, and marginally impairs picture quality. You might also lose the subtitle depth information, which is annoying.

If you mean a way of adjusting the depth of the actual movie image, there is no setting for that. You can tweak subtitle depth a bit, and the strength of the 3D effect that is applied to Kodi’s menu UI in 3D mode, but that’s about it.

Yeah, the Pi works well in 3D. In my personal, highly subjective opinion, the 3D image quality on the Vero is marginally better than on the Pi. But the main advantage is that it can also handle 4K HDR video, and pass through DTS-X and Dolby Atmos audio. The Pi 3 can’t do either of those; it won’t need to for 3D films, but if you want a single library and a single playback device, the Vero may well be the better choice.

1 Like

It does if you remux the videos to include those tracks! For example, I have the 4K/3D set of “Alita”. I combined the Atmos from the 4K version with the rest of the audio from the 3D version. I’ve actually done that with all my MCU movies too when possible.

So is this saying that if I get my new Vero (hopefully soon!) i can run this commend line and it will “downgrade” the device to a build of OSMC that supports HD audio AND 3D as I’m looking for?

sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

If so what is the advantage of using a newer version?

The primary advantage is that Sam and the dev team get important information from users who have some competence in testing software and providing meaningful and actionable information so that outstanding usability issues may be found and resolved. Such is the path toward ultimately making the testing builds the stable, widely disseminated version. The current testing builds simply do not have the 3d function cooked in at the moment. Things have to be prioritized.

Secondarily, if you wish to continue discussing in this direction, please create a new thread so the focus here can remain on point.

That command is the final stage of the process. There is some other stuff you need to do first to install the v4.9 kernel.

It is more stable. If you’re going to install test software, you need to be comfortable with the fact that it won’t always work correctly.

I’ll update the Kodi review to mention 3D functionality requires the appropriate Beta build.


Hi @sam_nazarko sorry to resurrect this, but I’ve reinstalled OSMC on Vero4K with 3.14 kernel for debugging. Now it is possible to communicate over USB serial.
When I plug in a Wemos D1Mini board, dmesg says:

[ 390.513073] usb 1-1.2: new full-speed USB device number 6 using xhci-hcd
[ 390.613802] usb 1-1.2: New USB device found, idVendor=1a86, idProduct=7523
[ 390.613814] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 390.613819] usb 1-1.2: Product: USB2.0-Serial
[ 390.691708] usbcore: registered new interface driver ch341
[ 390.691753] usbserial: USB Serial support registered for ch341-uart
[ 390.691786] ch341 1-1.2:1.0: ch341-uart converter detected
[ 390.692822] usb 1-1.2: ch341-uart converter now attached to ttyUSB0

on 4.9 it was:

osmc kernel: usb 1-1: USB disconnect, device number 27
osmc kernel: usb 1-1: new full-speed USB device number 28 using xhci-hcd
osmc kernel: usb 1-1: New USB device found, idVendor=1a86, idProduct=7523
osmc kernel: usb 1-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
osmc kernel: usb 1-1: Product: USB2.0-Serial
osmc kernel: usb 1-1: Unsupported device

How is is possible to find the CONFIG_ options for the kernel?


I recall adding some changes which should resolve this for the next kernel build.
Give me a shout if this isn’t the case after it’s released



1 Like

Do you mean the next 3D build or should we install always the latest updates (kernel drivers linux) and than back the kodi 3D build?

I’ve just updated with the apt-get update && sudo apt-get dist-upgrade command.

What I’ve right away noticed with a HDR content that it’s darker like it was before the update.
It’s easy to compare as I was in the middle of the movie when I had the idea to update.

Is this normal ? Anyone noticed the same ? TV is LGC7

Metadata passthrough wasn’t working properly with 3.14. The colours on your LG should now be ‘correct’.

BTW the LGC7 doesn’t seem to do HDR10+, or have they upgraded it?

Indeed no HDR10+, C7 supports HDR10, DV, HLG and “Advanced HDR by Technicolor”.

Can confirm. It was still worth to upgrade if the Metadata passthrough is working properly now after all these years. It’s a bit sad though that this happend just now as nowadays most of the time I watch almost only DV content.

I guess if you have DV material, it will be played as HDR10 in the absence of DV support on Vero. As such, proper handling of metadata should still be worthwhile for you.

I was just puzzled why you were asking after HDR10+ when you can’t display it.

Sorry mate I think you missunderstood me. What would be to point to watch DV content on a player that would display it as HDR ? While I would love to play DV content too on my Vero I need to use something else that excels in this one specific area.

Oh yes. I guess your TV would always be able to play it. Ignore me.

Folks - just a quick one. To progress from this test build to the “next” full mainstream update, we just remove “http://apt.osmc.tv videoimprovevero main” from the sources.list file, or is there more to it.


Unfortunately not. There is no upgrade path at this time.
You will need to reinstall.