[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

What version did you have when you first noticed the problems? Kodi 18.7, stretch I guess, but 4.9 or 3.14?

Logs would be useful.

Hi Graham,

Here’s the log: https://paste.osmc.tv/nehavovino

As it turned out, the Atmos was an AVR issue - my bad!

The .DSF issue persists, though… I’m seeing pretty high CPU usage (170 - 250%), if that provides a clue.

I’m on the 4.9 kernel. The problem started well after I updated to 18.7, so I’m not entirely who the culprit is!

TIA - I really appreciate your help!

  • Erik

The Vero can’t cope with DSD files, I would suggest you convert them to flacs, I did that with all and no problems since then.

The only issue I still have is with multi channel flacs in the summer, that takes alot of cpu as well and thus temperature hitting the max temp allowed.

It can. Or rather, it could :slight_smile:

It’s been possible since 18.0

The file in the log played back perfectly until about a month ago. AFAIK, Kodi transcodes the DSD-stream to PCM, meaning there is no real advantage to the DSD/DSF formats, and trancoding could be an option, but it’s a lot of work and shouldn’t be nescessary if everything was working as it should…

Good luck, been fighting with this every summer since 2018
The only suggestion I got was convert to flac, have spoke up about this a few times already…

The DSD conversion Kodi does is a generic one to 192 kHz 24 bit. Most of the time this is not what is recommended, if converting DSD to PCM more or less properly. It’s putting a lot of stress on the device to do this in real time. As the format is quite rare and there’s no proper way (DSD passthrough, DoP) to output DSD with Vero/Kodi, we probably won’t invest much time into this. There’s a clear remark about this in our audio wiki as well: Audio hardware and software configuration

script.tvmelodies seems to be very busy. Does it get better if you disable it?

Uninstalled it (wasn’t even aware that that I’d installed it in the first place) - no difference :frowning:

Edit: 2-track DSF files plays back perfectly. I’m guessing the CPU is somehow the bottleneck…

If 5.1 worked before, what it might be is we recently added the 192kHz sample rate to HDMI output. As an experiment, you could try setting audio to Fixed with a maximum rate of 96kHz or less and see if that helps.

Tried it. The dropouts still come at regular intervals, if I lower the maximum samplerate, the space between them increases (ca. 1 second apart @ 44.1 KHz) and the playback speed, which appears to slow down as the samplerate increases, approaches normal.

In short: better, but still far away from OK!

Can you upload a 10-20sec sample of the file somewhere?

Have you checked the temperature of the device when you have the dropouts?
My vero went because of the 100% cpu load to 110C, that is what the issue is, it throttles down to save the cpu from overheating.

You can check by commandline with:

cat /sys/class/thermal/thermal_zone0/temp

My idle temp is 62C at the moment, playing a multichannel flac will get that beyond the 100C after quite a few numbers, so not right away, you have that same issue?

Hi,
I am back to report here, that after several videos played yesterday I have experienced the green video play problem again (on all the videos I have started, subs, audio, menues are still correct).
After report I have also experienced the Vero detaching from the network, but that is now being handled in a separate thread: Network issue after recent update - #2 by fzinken seems like an ARP issue, trying to find the root cause there.

As for the green video: this did not happen during the week on my other Vero4k+ that still runs the old kernel, debian and kodi, so I am reasonably certain it is because of either of the 3 upgraded components. Let me know what to do logs once it happens again to get you more useful logs.

I need logs to get any understanding of your problem, and it should be continued in the separate thread.

I know, that is why I asked what logs. The generic logs I posted last time did not seem to be of any help.

Also I think:
-> the ARP / Network detach issue should be continued in the Network issue after recent update - #2 by fzinken thread.
-> however the green video - I think - should be investigated here as others here also have experienced it. But if you have a separate thread for that too, I am happy to oblige just point me to it.

Regarding the green video: I think it’s kernel related. I’d suggest to ssh to the Vero and issue that command right after it happened:

cat /sys/class/video/dump_reg

and then send us the logs.

And it would be great if someone could come up with an easy way to reproduce it :smiley: .

hi @tanio99
i am not sure if we think the same green video. But i spotted strange green picture when i switch on my tv to 4K NASA channel. Its just a few miliseconds, I can see it thanks to ambilight which become in the meantime of switching green coloured. I uploaded video to videosam.pl or u can got see it on youtube. Hope it helps

Until now, it was very easy to reproduce by jumping back or forwards. But, I just installed an update, rebooted Kodi and now it doesn’t happen anymore. The filenames of the update indicated a LIRC related fix so am not sure why the issue isn’t happening anymore.

Please note that it only happened with two MKV files which were created by mkvtoolnix 40.0.0 so maybe that’s related?

This should only happen if you switched from one stream to another.
It should be fixed in the next 4.9 kernel update.

AMLogic have provided an upstream solution for this, but we have not included it in our builds yet.

I’m still having the same problem with my Harmony remote. The select/ok button does not work. All other buttons seem to work fine. I’ve posted my slightly edited logs here:

http://paste.osmc.io/zatamufoso.vhdl

To help, during the logging process I started using the remote at 12:43 and stopped at 12:44. During that minute, I would go right a couple times through the movie list on the home page and then try the select key. I’d repeat this until the end of the movie list, then go down one and try this process again.

Also, the select/ok does not work on the harmony app.

Hopefully this is solvable since the select key is an important one :slight_smile:

Thank you.