[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

I have those two movies also in 3D iso files and will test them out when I get the time tomorrow morning.

Just watched The Walk 3D and it was perfect. I have to say this is the best the vero4k has worked for me. Everything seems snappier. Especialy with the menus. So far so good.

Yes, it’s the same issue. I’ve already had a look at that problem. It’s not easy to solve and will need a bigger refactoring of how 3D ISOs are being played.

The problem is that currently the info about where a frame of the second eye stream can be found isn’t used. So if you skip then the stream has to be sequentially read until the correct location was found. And that takes time.

IIRC @angry.sardine has already verified that it doesn’t work on the Pi, too.

When zapping backwards the video decoder seems to crash and the video is replaced with green (fullscreen). You can stop the video and the gui still works but when you play a video the you only get the green screen again. Only a reboot brings things back to normal.

Until know I can reproduce it with two HDR UHD MKV files (created with 40.0). If this isn’t a known issue I can upload full debug logs later today.

I’ve been having some audio issues for the past few weeks: Dolby Atmos now plays back as DolbyTrueHD and multi-channel .DSF files have begun stuttering. I’ve made no changes to my settings, and all other formats are playing back as they should. I was hoping the latest update would have fixed it, but that’s not the case. Any ideas?

What version did you have when you first noticed the problems? Kodi 18.7, stretch I guess, but 4.9 or 3.14?

Logs would be useful.

Hi Graham,

Here’s the log: https://paste.osmc.tv/nehavovino

As it turned out, the Atmos was an AVR issue - my bad!

The .DSF issue persists, though… I’m seeing pretty high CPU usage (170 - 250%), if that provides a clue.

I’m on the 4.9 kernel. The problem started well after I updated to 18.7, so I’m not entirely who the culprit is!

TIA - I really appreciate your help!

  • Erik

The Vero can’t cope with DSD files, I would suggest you convert them to flacs, I did that with all and no problems since then.

The only issue I still have is with multi channel flacs in the summer, that takes alot of cpu as well and thus temperature hitting the max temp allowed.

It can. Or rather, it could :slight_smile:

It’s been possible since 18.0

The file in the log played back perfectly until about a month ago. AFAIK, Kodi transcodes the DSD-stream to PCM, meaning there is no real advantage to the DSD/DSF formats, and trancoding could be an option, but it’s a lot of work and shouldn’t be nescessary if everything was working as it should…

Good luck, been fighting with this every summer since 2018
The only suggestion I got was convert to flac, have spoke up about this a few times already…

The DSD conversion Kodi does is a generic one to 192 kHz 24 bit. Most of the time this is not what is recommended, if converting DSD to PCM more or less properly. It’s putting a lot of stress on the device to do this in real time. As the format is quite rare and there’s no proper way (DSD passthrough, DoP) to output DSD with Vero/Kodi, we probably won’t invest much time into this. There’s a clear remark about this in our audio wiki as well: Audio hardware and software configuration

script.tvmelodies seems to be very busy. Does it get better if you disable it?

Uninstalled it (wasn’t even aware that that I’d installed it in the first place) - no difference :frowning:

Edit: 2-track DSF files plays back perfectly. I’m guessing the CPU is somehow the bottleneck…

If 5.1 worked before, what it might be is we recently added the 192kHz sample rate to HDMI output. As an experiment, you could try setting audio to Fixed with a maximum rate of 96kHz or less and see if that helps.

Tried it. The dropouts still come at regular intervals, if I lower the maximum samplerate, the space between them increases (ca. 1 second apart @ 44.1 KHz) and the playback speed, which appears to slow down as the samplerate increases, approaches normal.

In short: better, but still far away from OK!

Can you upload a 10-20sec sample of the file somewhere?

Have you checked the temperature of the device when you have the dropouts?
My vero went because of the 100% cpu load to 110C, that is what the issue is, it throttles down to save the cpu from overheating.

You can check by commandline with:

cat /sys/class/thermal/thermal_zone0/temp

My idle temp is 62C at the moment, playing a multichannel flac will get that beyond the 100C after quite a few numbers, so not right away, you have that same issue?

Hi,
I am back to report here, that after several videos played yesterday I have experienced the green video play problem again (on all the videos I have started, subs, audio, menues are still correct).
After report I have also experienced the Vero detaching from the network, but that is now being handled in a separate thread: Network issue after recent update - #2 by fzinken seems like an ARP issue, trying to find the root cause there.

As for the green video: this did not happen during the week on my other Vero4k+ that still runs the old kernel, debian and kodi, so I am reasonably certain it is because of either of the 3 upgraded components. Let me know what to do logs once it happens again to get you more useful logs.

I need logs to get any understanding of your problem, and it should be continued in the separate thread.

I know, that is why I asked what logs. The generic logs I posted last time did not seem to be of any help.

Also I think:
-> the ARP / Network detach issue should be continued in the Network issue after recent update - #2 by fzinken thread.
-> however the green video - I think - should be investigated here as others here also have experienced it. But if you have a separate thread for that too, I am happy to oblige just point me to it.