[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

Regarding the green video: I think it’s kernel related. I’d suggest to ssh to the Vero and issue that command right after it happened:

cat /sys/class/video/dump_reg

and then send us the logs.

And it would be great if someone could come up with an easy way to reproduce it :smiley: .

hi @tanio99
i am not sure if we think the same green video. But i spotted strange green picture when i switch on my tv to 4K NASA channel. Its just a few miliseconds, I can see it thanks to ambilight which become in the meantime of switching green coloured. I uploaded video to videosam.pl or u can got see it on youtube. Hope it helps

Until now, it was very easy to reproduce by jumping back or forwards. But, I just installed an update, rebooted Kodi and now it doesn’t happen anymore. The filenames of the update indicated a LIRC related fix so am not sure why the issue isn’t happening anymore.

Please note that it only happened with two MKV files which were created by mkvtoolnix 40.0.0 so maybe that’s related?

This should only happen if you switched from one stream to another.
It should be fixed in the next 4.9 kernel update.

AMLogic have provided an upstream solution for this, but we have not included it in our builds yet.

I’m still having the same problem with my Harmony remote. The select/ok button does not work. All other buttons seem to work fine. I’ve posted my slightly edited logs here:


To help, during the logging process I started using the remote at 12:43 and stopped at 12:44. During that minute, I would go right a couple times through the movie list on the home page and then try the select key. I’d repeat this until the end of the movie list, then go down one and try this process again.

Also, the select/ok does not work on the harmony app.

Hopefully this is solvable since the select key is an important one :slight_smile:

Thank you.

yes @sam_nazarko you’re right just if i switched from one stream to another. Thanks for explanation.

You posted only your slightly edited Kodi log which with this issue is useless as is an OS level issue which keeps the control being sent to Kodi in the first place so it shows nothing in Kodi’s log when you push the button. Full logs would allow someone to see if you really are running the version that fixed this issue. Also you did not provide enough info to allow someone to reproduce. You can program a Harmony with different profiles that work with the Vero. Which profile are you using in the Harmony software? Mine works just fine with “Media Center PC” profile paired with “rc6-mce-lircd” selected in MyOSMC.

My understanding was that this is how to produce logs:
enable debug logging. restart. then reproduce the issue. stop debugging.
This is what i did.
I then posted the log as it was exactly from /home/osmc/.kodi/temp, with the only changes being deleting TV shows that showed up as well as IP and passwords. No other changes were made. I do this to protect my privacy.

Perhaps there was a change to the settings that did not provide more logs. If you can advise, please let me know.

In response to your other points, I have been using the “OSMC Media Player” profile in Harmony. This has worked perfectly prior to the September 19th update and the issues I mention here was not corrected after downloading the fix referenced in Sam’s post to which I replied.

I look forward to hearing any suggestions that you might have.

As explained in our wiki

Sanitizing your logs

While generally the script tries to hide all passwords we know that certain people still are not comfortable with any information shared. If you are one of those first create the file locally, edit it and then upload it. To do so use:

grab-logs -A -C
nano /boot/uploadlog.txt
paste-log /boot/uploadlog.txt

If you upload a such altered log file please let us know so that we don’t wonder about possible gaps.

Is that one the IR or the bluetooth profile? If it is the former I can test it myself.

EDIT: I tested Harmony’s IR profile “Vero 2” and I got a working OK button. I don’t have a BT remote to test those profiles. They all show up as “OSMC Media Player” so you have to go to the “devices” section of the software to see the actual name of the device that was programed in.

The issue has been confirmed as fixed by several people. Without full logs it’s not even possible to tell if you have indeed installed the update or if the issue you are experiencing is related.

I’m sure with a bit more information we can get to the bottom of this.


Hi Graham,

the smallest file I have is around 182mb and I’m not sure how to split these files - Google was somewhat uncooperative :slight_smile:

You can download DSD64 files from here: 2L High Resolution Music .:. free TEST BENCH

I downloaded the relatively small (94mb) Vivaldi sample near the bottom of the page and was able to reproduce the stuttering immediately.

1 Like

My apologies regarding the logs. Here is a new slightly edited version. I did the same thing to reproduce the problem as before - going right and then hitting ok/select. All from 2:59 to 3:00.


On the device page, the name under the icon is “OSMC Vero 4K”, while the Device name (which appears user editable) is “OSMC Media Player”. Hopefully one of those is the one you’re looking for.

The Harmony remote that I’m using is this:

I apologize in advance but I am not completely sure if I’m using the bluetooth or IR on this. I believe it is IR since I have not setup bluetooth on the Vero 4k, and I am using the IR connector attached to the 4k. Once I get something setup, I seem to lose a lot of knowledge as to how I did it.

Hope this is enough to help. If not, please let me know. Thank you.

A helpful hint going forward, obscuring your local private IP addresses is a complete waste of your time. They are the same for everyone. I can tell you this workstation I’m on now is and it is exactly useful to no one. This is all protected by your router/modem/firewall.

1 Like

I’m at a loss on why you are having an issue. Your install looks to be correct from your logs and I cannot reproduce the problem. I added a “OSMC Vero 4K” device to a Harmony 650, switched the remote profile over to the same “osmc-remote-lirc” conf your running, but my OK button is working in this configuration.

Thanks for checking. When I have time later today, I’ll delete the OSMC Vero 4k from harmony and re-add it. Perhaps something went screwy with the Harmony software. I’ll let you know how that goes.

If your going to go through the hassle of reprogramming your remote then do it with “Microsoft Windows media center” instead as it seems to be a bit more responsive than the Vero profile. You will have to also switch the configuration in My OSMC over to “rc6-mce-lircd” before it will work.

The deleting and adding it back in worked! Unfortunately I did that prior to reading your post, but i’m happy that it’s working now. Not sure what it was but I do appreciate your help here.

1 Like

Just installed 4.9 and I can now playback frame packed 3D after manaully switching my TV to 3D mode.

Will automatic switching of the TV to 3D mode be added at some point?

3D mode enables automatically with my projector, as it should with most displays, when they detect a 3D signal.

Not working with my LG OLED, when I ran a Raspberry Pi with Libreelec then it switched automatically so I know its a Vero / OSMC related issue.