[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

For those having ssh issues, double check your network settings. The new kernel test update reset my network settings back to dhcp from my static ip. Had to change back to my static ip. Ssh was fine, it was the ip change.

Are you using Kodi paths? If so, try a system mount. This behavior sounds like what happens when it is struggling to keep up with (relatively) high bandwidth files.

I’m added the folders via Kodi browser using nfs protocol. My network is gigabit ethernet, and this doesn’t suceed with mkv files (it run 60Gb mkv files without troubles).

The problem is that when appears the “Loading …” text it doesn’t disappear, I can wait 10 minutes, and it’s hanged there, but if I press pause, or forward a bit, start working fine again.

I understand that. I had the same issue in the stable build that did the same thing. I had plenty of bandwidth for the size of the rip, but it had issues anyway. After adding my source as a system mount and putting in a path sub to point my existing library over to it the files played without issue. This is frequently required for people using a Vero and playing larger files.

1 Like

So is better mounting the folder in fstab and later add to Kodi, correct ?

If you make a system mount with fstab you can test the function by playing though the file manager in settings. If that gets you to where you want to be you can either completely redo your library from scratch or just add a path substitution which will just redirect Kodi to this new location without changing anything else in Kodi or your existing library.

I find that a change of kernel will change the device’s public key. With ssh from linux, I just get a warning to delete the key from known hosts, then I re-connect and accept the new key for that IP. Somethings similar happens with putty. Windows filesharing doesn’t give you a warning but the trick seems to be to delete the relevant entry in Credentials Manager.

I can’t help with Apple stuff.

Can you send me please the output of following command?

cat /sys/class/amhdmitx/amhdmitx0/disp_cap_3d

Yes the same is happening to me, yesterday though when I enabled logging I wasn’t able to reproduce , but still happening randomly , when stopping movie or show , I get the sad face and vero restarts.

1 Like

I tried playing from file explorer a nfs mounted via fstab and have the same problem:

  • m2ts UHD files: have the problem I explained.
  • m2ts 1080p files: works fine
  • mkv 65gb files: works fine

Also I don’t know why, but I lost the HDR capability, 4k worked fine but without HDR. A reboot solved it.

Thanks

SSH through macOS Terminal behaves in a similar manner with public key changes, it caches it in ~/.ssh/known_hosts and will fail to connect before warning of mismatched key.

Remove the offending key or the known_hosts file and off you go.

1 Like
720p50hz FramePacking TopBottom SidebySide
720p60hz FramePacking TopBottom SidebySide
1080p24hz FramePacking TopBottom SidebySide
1080p25hz TopBottom SidebySide
1080i50hz SidebySide
1080i60hz TopBottom SidebySide

Just one small issue for me so far. After the update I had no sound for H264 files with AC3 encoded audio (MPEG2 files with AC3 audio were fine). I went into the Kodi settings and changed the audio from the default to HDMI only and I got sound on all files. Then I changed it back to the default (HDMI, SPIDF, analog) and it kept working. Overall it does seem snappier, although that could be confirmation bias at work.

The updated GPU driver should provide some performance improvements here.

Ok that was the issue. Strange thing is a new install of Debian Buster (10.2 image from a few months ago) does not have those ciphers enabled.
Anyway it’s fixed and I only access Kodi over the LAN or via a VPN to home so it’s all ok I think.

Yeah it does that in Putty but then you just click update and you’re good to go. I was just that specific iOS App and I fixed it by editing out the cipher settings. Thanks.

Working quite well so far. One thing I noticed, however, is that if a particular film had a different Contrast setting other than the default of 50, it always plays initially with a default Contrast setting of 50. If I make any adjustment to the Contrast it’ll play at the new value. For example, if I have a 4K film that I’ve set with a Contrast of 58, lowering it to 57 makes the picture brighter (because it actually adjusted the Contrast from 50 to 57).

Thanks, I’ll check this.

Question - Is there a setting somewhere to enable the HDR to SDR conversion or adjust the tone mapping on a per title basis? I’m not seeing much difference in kernel 4.9 compared to 3.14 (which as already quite decent, albeit still a bit on the dark side).

1 Like

For now, this could be adjusted by the command line.

We will look at tone mapping in more detail soon

Sam

1 Like