[TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +

Hi Sam

Thank you for your response. With the new kernel I’m now past the ‘addrtype’ error and am able to start the docker daemon and pull images but when I go to start a container I get the error below. Googling the error brings up a few results where people suggest a kernel issue. I’ve also attached the kernel checker results in case that’s of interest.

[edit]@sam_nazarko following on from the above it could be because “- CONFIG_VETH:” is missing from the kernel

1. root@osmc:/# docker start xxxxx

* Error response from daemon: failed to create endpoint xxxxx on network MyNetwork: failed to add the host (veth14y754d) <=> sandbox (vethcdc51eb) pair interfaces: operation not supported

* Error: failed to start containers: xxxxx


Hi Sam, since the upgrade TVHeadend client doesnt work, i have updated both units, one with server one with client

On client, I have EPG, and I can see recordings but when i select to watch any (recorded or live tv) i get TVHeadent HTSP client no signal.

It was all working yesterday :frowning:

The server i can access on http and set a recording, the client shows, started/stopped recording, but theres no recording on the hard drive :confused:

Well logs might help :wink:

well this is odd and im totally confused, i have tried few times 3-4 rebooting both server and client and always got same result, enabled logging with bellow added to advancedsettings.xml

<loglevel hide=true>3</loglevel>

And everthing worked, set that now to false, on first boot it didnt work, and now it is :expressionless:

1 thing i did notice on the status in tvheadend http, it was showing a signal status intimitedly that i didnt thing osmc supported?

one odd thing is the led on the server osmc is red instead of blue, but all seems to be working now :confused:

I have problems with skipping chapters yet, but I suppose it’s just not a great x265 encode? It would freeze a frame after skipping or start from the beginning but sped up. I don’t know if it’s specific for this 4.9 version, so please don’t consider my report as certainly valid.

Edit: here’s a sample episode http://a.tmp.ninja/qXN8kI1GEkyM.mkv

Are you using passthrough audio? I have two 4.9 Vero’s, the one set to passthrough in my main system is behaving. I have another which I just connected to my kitchen system, with PCM audio for the soundbar, and chapter skipping is very broken. I posted a log with passthrough disabled a few posts up, here is a fresh log from my second system. Chapter skipping sometimes works, but often leads to a sad face. This is happening with blu-ray and UHD-sourced mkv’s.


By the way, it’s a while since I looked at SDR conversion for HDR mkv’s. I’m impressed with how most titles look. I would say that the SDR conversion of UHD-sourced mkv’s is still under-shooting on brightness/contrast slightly compared to the blu-ray sourced mkv’s. But my impression is that the SDR conversion is more watchable than it used to be, and getting very close now to native SDR.

@ac16161 No, I’m actually using 3.5mm on the Vero itself, and all the pass-throughs are disabled.

Hello darwindesign,
I just want to say: “Thank you.”
Your 49er :slight_smile: sent me to the right direction to solve my 3D Problems… after a looong time of troubleshooting.

1 Like


I count 25 config items marked as “missing”. Some, like CONFIG_AUFS_FS, are possibly no longer needed but that still leaves the other 24.

Rather than repeatedly finding further items that are needed but missing, is there any chance you can find out which ones are definitely needed, which are probably/possibly needed and those which are not needed?

This seems like quite an antagonistic reply to me but I’ll try to address the point as best I can. As I said earlier, I’m not a programmer, but all I can say is that Docker worked on the 3.x kernel and not 4.9.

Sam said himself in an older thread that Docker works in 4.9. So I updated to 4.9 to discover that it doesn’t. I understand that 4.9 is “beta” or whatever you might call it and all risk is on me should I decide to upgrade so I try not to get too aggrieved with the situation. I’m now in a position though where Docker isn’t working and I don’t have the time/skills to downgrade and start again so I’ll try as best as I can to provide the logs that assist with the kernel additions required to get docker working as it did before.

All I can do is try the new kernels given and provide feedback on what I believe to be the problem based on Googling and educated guessing. Without trying to be rude I assume Docker isn’t actually tested by Sam/the OSMC crew before releasing the kernel as ‘Docker fix’ is often listed even though I keep finding it hasn’t actually worked.

I assume Aufs isn’t needed any more as I configured for overlayfs which got me past that error.

The “CONFIG_VETH” suggestion I believe has some merit as it’s required for the virtual ethernet that is created by Docker and you can see it mentioned in the error I’ve given. I couldn’t tell you what else is definitely required though pretty much all else under “generally required” is enabled on the current kernel according to the script checker.

Apologies if I’ve misread the tone of your reply but I am incredibly anxious to get my docker containers up and running again and feel like I’m being a nuisance every time I respond to a new release with “nope, not working again”… But if Docker isn’t being tested on the kernel release side then what else is there for me to do?

Absolutely not my intention. I don’t use Docker in any meaningful way, so I was hoping that you might be able to help Sam put this issue to bed for good.

If anyone else with Docker expertise can contribute, that would also be appreciated.

I’m getting tons of frame skips with the film Gemini Man (4k 60fps HDR). It succeed specially on fast movements my moments of the film.

My Vero 4k+ has the latest beta kernel, and it’s connected to a NAS via NFS mounted on fstab. I think that it’s not a network problem, since others mkvs with bigger bitrate doesn’t have this problem. (For example Avatar or ESDLA).

It’s connected via AVR to the TV (Denon x3700h), but I’ve tested directly to a TV HDMI port and have the same problem. I try different HDMIs cables with high bandwidth, with the same problem.

If I toggle debug mode, the cores of the CPU isn’t overloaded and the device isn’t overheated.

How can I give you more data about this? I can activate the debug mode and upload logs, but not sure that they give needed information.

Pd: Is not a problem for me, since is the only film I’ve problems with, but maybe is interesting for kernel stabilization.

It would help to know how long you’ve been using the 4.9 kernel for, so we can work out if this is a regression in a recent build or if it’s been problematic for a while.

The debug logs might not give us everything, but they would definitely be useful.

Can you give a timestamp so it’s easier to reproduce?

I use this kernel about 6 months ago, but I sold my old Vero 4k+ because my old av receiver didn’t support 4k. I bought a new one now that I have a new receiver, and I own it since a week ago. I installed directly the latest kernel version.

I think that I don’t have this problem in May or June 2020, but not sure.

I’ll upload logs in a few hours as soon as I return home.

I’ll give you more precise information later, but for example in the first moments of the film the the logo appears, or in the scene of the motorbike when the clone is fighting with the main character of the film.

Can’t reproduce here

Maybe your Rip is bad. Maybe try to rip it again.

You have 88 skipped frames on this image (maybe this suceed in anither moment of the film.

Maybe my rip isn’t good, I’ll try another one, but works fine with the Panasonic own player, and worked fine with my old Oppo 203 clone.

I have recently noticed one small glitch which I don’t remember seeing before (but I may be wrong, I admit I haven’t tried 3.14 in a long while). When there is no video playing, the UI is exactly as it should be. But as soon as I start any video, or TV stream, the UI is always slightly bigger, going behind the edge:

The video itself is ok, here you can see the TV station logo is as expected, but the overlay with movie title, the time and end time, the “stopped” text at the bottom… all are cut. I tried different video resulutions, no change.
It may be a problem with my setup, unrelated to kernel version, but search here didn’t find anything so far.

That mainly happens when skipping forward and backward. When I go to 00:40:00 and stop the movie and start from there I don’t get skips during the motor cycle scene.