[TESTING] OSMC images for Debian Stretch


Issue: Vero 1, black screen after installation.

Additional information that might be helpful

  • after OSMC file installation you get a black screen but the SPDIF port’s red light stays OFF (does it mean the box wasn’t rebooted?)

  • power off/on the box after some minutes let stay the SPDIF port’s red light ON all the time (does it mean the boot loader did not even start/complete at all?)

  • appending rescue or recovery to uEnv.txt has not effect, no console output


There was no first automatic apt-get update on the first login, when it’s that what you mean?


There was no first automatic apt-get update on the first login, when it’s that what you mean?

I’m wrong it does from SSH

So now I can be more concrete, after an SSH-Login and the resulting Updating APT Cache the install of the Samba-Server from the GUI works fine


Hi Sam

I downloaded a clean install from your link yesterday and it all seems to be working perfectly.
I will keep a look out for my previous Surround Sound issues but at the moment they too seem to have disappeared.
Good job & thanks.


Thanks, that makes sense.

The installer would still be compiled against GCC 4.x for both kernel and bootloader; so no surprises there.

I will look in to this shortly.



Thanks for confirming means seems to be the missing cache building of the App Store. Very likely not many people went to the App Store first thing so therefore didn’t see it before.

Vero update

Proud that I could help


Btw. are there some mesurements to compare OSMC jessie and stretch?


the guys on the RPi forum have probably tested it


Vero 4K (Early 2017)

Everything installed without problems. Samba needed a reboot of the device to show all items from the media folder.
Everything else is working perfectly so far.


My RF remote has stopped working after migration to debian-stretch Kodi v17.6 clean installation on rpi2
the issue is that the all keybord key and the enter /home/R-Mouse/Back button no longer work, except the gyroscope move of mouse cursor are getting valid signals.
i try this topic https://discourse.osmc.tv/t/solved-my-rf-remote-has-stopped-working-after-migration-to-kodi-v17/22118 but dont resolve the probleme


I installed the image for my Pi 3. The installation itself went fine. I selected German as language, Berline as timezone and the Classic skin

As soon as the KODI screen appeared I immediately (no reboot in between) went to my OSMC and then to the App Store. There I selected the FTP Server, Samba and Cron for installation.

The system tried to install but it failed and the popup told me to report to the forum. After clicking OK I got another popup that reported a success.

But if I go back to the App Store the packages I tried to install are not shown as installed.

Uploading Logs via the UI has not worked. I selected upload but no URL was shown. I then did it via the command line.




next issue: as mentioned in my previous post I selected the Classic skin. but after a reboot I suddenly have the OSMC skin active.

before the reboot I did via command line:
“sudo apt-get update” and rebooted.

After the reboot I am still not able to install the apps via the app store but the new issue is that OSMC now has the OSMC skin active instead the Classic skin I selected during the installation.

After changing it back to Classic/Estuary and another reboot KODI now has the correct skin.

This should not be the case.


I can’t reproduce that here. If you can produce it reliably please submit some debug logs


hmmm I am not able to reproduce the skin change any more. I tried exactly the same steps (with a fresh installation) but this time it did not happen. The only difference was that I enabled the debug logs…I also tried to install via the app store as before…


It’s all about the missing cache building of the App Store. I had the same Problem


Can anyone reproduce this with a Jessie image?


Can anyone reproduce this with a Jessie image?

You mean the issue with cache and App Store? I just tested it with the 2017.10-1 image for PI 2/3 and there it works fine. I went immediately to the App Store after the installation completed and was able to install FTP Server, Samba and Cron.
If I do the same with the testing Stretch image it does not work.



Will the OSMC DVB-T2 TV Dongle completely supported with the coming Debian Stretch update, especially I’m interested in the German DVB-T2?


No – the focus was on Stretch here. Once that is done, we can make that testing available early next week. Otherwise Stretch will keep getting pushed back and we won’t ever get it out.