Testing RetrOSMC 0.009 Beta


Hello everyone,

This is a betatest! I did some installations myself and it seems to be working. Still: Do not expect everything to work.
Also I am not responsible for any problems with your system when testing this.

I made some alterations to my scripts.
So I kindly ask you to test them.

The best way to do so is to have an osmc install without RetrOSMC installed.

Now you only have to install the addon from zip. If you run it and do not have RetrOSMC installed, it should ask you if you want to do so.

Other changes are, that you can now access settings like CECFIX and HYPERIONFIX from the addonsettings and start the retrosmc installscript and the retropie setupscript from there.

Also you can setup scripts to run before and after emulationstation starts/quits.

You will need a connected gamepad or keyboard to navigate the menus though. Make sure they are recognised by Kodi by setting them up in the input menu.

You can also install this by traditionally download the script via ssh and run it from the home folder but I’d like to test the install from the addon.

Please get the addon from here:

Let me know if there are any problems.

You can check the new code on github:

Edit: If you want to update an existing installation, delete the old install-retrosmc.sh script from your home directory, download the install-retrosmc.sh script from here:

Make it executable:
chmod +x install-retrosmc.sh

Run it:

and select “Update scripts” and “Install/update Launcher Addon”

[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC
[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC
[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC

Installed via the addon from zip, everything worked flawlessly.

Couple minor issues for me. Apologies if these are unrelated/have been reported already, the other thread is massive.

  1. On reboot sound was missing. Had to re-select the overlay in the Pi Config in My OSMC (HiFiBerry DAC pro plus) and restart.
  2. I was lazy and didn’t configure my wired Xbox 360 controller in Kodi before installing. The controller has been configured nicely in RetroPie and works, but the 4 ring LEDS haven’t stopped blinking since I plugged it in (even after restarts)
  3. Launching the RetroArch GUI, the Xbox 360 controller doesn’t work.

Guessing the last 2 issues would be solved using this method?


Yes, sorry. Wireless xbox controllers can be a pain and I don’t have any to test, so please use the other thread to get them working.


Mine is wired, although it is the PC version. I will try the other thread and report back. Thanks.


This will only work on a Raspberry Pi 1, 2 or 3! NOT on the Vero.

:weary: And no plans to try and get it to work on vero or vero2 since op hasn’t got a vero device, am I right?
My inital plan was to wait for team kodi to integrate retroplayer to kodi v17.
But it hasn’t made it into krypton :frowning: and some retrogaming on my vero2 would be nice.


RetroPie is also quite heavily built against MMAL and Pi libraries, which is why it’s a bit problematic.

@gmc will produce nightly builds for Kodi Leia for Vero soon which has RetroGaming support



I actually thought of trying to get a vero to port retroarch to it with a frontend, but as this is already worked on in kodi 18 and I don’t have a real need to get a vero device, I didn’t do it.


Vero 4K was only announced two days ago, and @gmc already has his first Kodi v18 build with RetroPlayer support ready: [TESTING] Kodi 18 (Leia) builds for Vero 2 & 4K.



Sorry for reviving

Just thought I’d mention, that this installer worked perfctly with stretch now that RetroPie supports stretch

Edit: Still the issue with starting without a keyboard. emulationstation doesn’t even get started. I think it’s the launcher binary. When you get time @mcobit please look at it.


Will this work on a Vero 4K running Leia?


retrosmc, is for pi only. But Leia can run retroplayer with a few working emulators right now (GBA, NES and Sega Genesis, these are the ones i got working right now)


OK good to know - is there anything I need to do for installation or just install the retrosmc add on?


Well installing RetrOSMC is simple, but it’s only for Pi as i said. You just install the addon and the first time it’s run it notice that retroarch isn’t installed and does this. This takes a rather long time, but once it’s done it should work. Don’t know if the addon is Leia proof yet but tonight i’ll test it out.

GMC’s nightlys contain retroplayer. All you got to do is enable the emulator you want, and make a source for your roms folder.

Tested RetrOSMC 0.009 beta on Leia works good


Thanks for the info - how do I actually get the emulator to run on Leia? I’ve gone to my addons and games, enabled the emulator I want but run is greyed out.


Okey, this is how i’ve done it:

First add a source: Games-> Add games -> Browse (navigate to your ROMs folder)

Then Settings -> Addon browser -> My addons -> Game addons -> Emulators and enable the one you want to run

I’ve tried most of them, these are the ones i got running:
mGBA(GBA emulator)
QuickNES(Nintendo 8bit emulator)
Sega (Genesis plus GX, handles MS GG MD and CD).

The rest mostly sadfaces and since a few updates every emulator sadfaces on exit. So it’s a work in progress


Did you manage to play any Genesis games? I Got the sad face after the Sega logo.


Then you got further then me with a Sega logo, but haven’t tried the latest leia yet.

Edit: sorry though you were talking about Saturn. Phantasy Star II works, but III doesn’t, IV does


Spoiler alert:
My Vero4k fork of RetroPie is currently undergoing the PR governance over on GitHub.
Had positive and constructive feedback so far, so just working on some suggested changes.

I’m currently running:
Retroarch -> SNES, PSX, Genesis, Game Boy, Atari 7800 and MAME-2003-plus cores;

Particularly proud of PPSSPP. That’s taken 8 months of tinkering on and off!

@mcobit Would you be interested in a PR to add the Vero4k to RetroOSMC? I already have one of the old beta I’m using.


This is brilliant to hear!
Can you send me a link to the PR?


Is this working? Would live to do some retrogaming on the Vero