Testing RetrOSMC 0.009 Beta

Okey, this is how i’ve done it:

First add a source: Games-> Add games -> Browse (navigate to your ROMs folder)

Then Settings -> Addon browser -> My addons -> Game addons -> Emulators and enable the one you want to run

I’ve tried most of them, these are the ones i got running:
mGBA(GBA emulator)
QuickNES(Nintendo 8bit emulator)
Sega (Genesis plus GX, handles MS GG MD and CD).

The rest mostly sadfaces and since a few updates every emulator sadfaces on exit. So it’s a work in progress

Did you manage to play any Genesis games? I Got the sad face after the Sega logo.

Then you got further then me with a Sega logo, but haven’t tried the latest leia yet.

Edit: sorry though you were talking about Saturn. Phantasy Star II works, but III doesn’t, IV does

Spoiler alert:
My Vero4k fork of RetroPie is currently undergoing the PR governance over on GitHub.
Had positive and constructive feedback so far, so just working on some suggested changes.

I’m currently running:
EmulationStation;
Retroarch -> SNES, PSX, Genesis, Game Boy, Atari 7800 and MAME-2003-plus cores;
Amiberry;
Reicast;
Mupen64Plus;
PPSSPP.

Particularly proud of PPSSPP. That’s taken 8 months of tinkering on and off!

@mcobit Would you be interested in a PR to add the Vero4k to RetroOSMC? I already have one of the old beta I’m using.

3 Likes

This is brilliant to hear!
Can you send me a link to the PR?

Is this working? Would live to do some retrogaming on the Vero

RetroPie-Setup was merged into master last night. Just waiting for EmulationStation to be merged in and we are there.
Note - it’s for the Vero4k only.

1 Like

Great news please keep us posted!

Wonderful job. Everything is installed/compiled properly. Emulationstation does not seem to compile unfortunately (i have tried the master branch, as it is not cherrypicked to stable yet, as well as the emulationstation-dev which is suggested on github as a temporary way of getting it to work). Both result in the following error sequence:

[100%] Linking CXX executable ../emulationstation
/usr/bin/ld: cannot find -lbcm_host
/usr/bin/ld: cannot find -lbrcmEGL
collect2: error: ld returned 1 exit status
es-app/CMakeFiles/emulationstation.dir/build.make:1151: recipe for target 'emulationstation' failed
make[2]: *** [emulationstation] Error 1
CMakeFiles/Makefile2:274: recipe for target 'es-app/CMakeFiles/emulationstation.dir/all' failed
make[1]: *** [es-app/CMakeFiles/emulationstation.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Any ideas? Thanks again for this huge effort!

Yeah I was waiting for stable to be caught up before starting a testing thread etc, but it seems to be taking a while. All busy people of course so I’m not pestering them. As you say, master was meant to work in the meantime but I guess not. Looks like it’s still using RPi libs there.

In the meantime you could use the stable branch of my repo for ES, which is what I’ve been doing all along.
https://github.com/hissingshark/EmulationStation.git

Thanks for trying.

Thanks, got it to work… apparently it detected bcm_host.h in an include folder (therefore the CMake VERO flag was off). I’m not sure how that bcm_host file got there, perhaps its there because i have been messing around with retropie and stuff before.
Emulationstation works fine and so do emulators. Only remaining issue is the Launcher addon runs emulationstation without quiting kodi (hence the screens interfere/flicker). How did you solve this for yourself, or do use ssh to quit the mediacenter service and run emulationstation by hand?

I use ps3 controllers, which i configured a while ago with some manual hacking with sixad. I’m not sure if this works out of the box for other people now. Thanks again!

Actually it seems to build just fine here. I’ve amended RetroPie-Setup/scriptmodules/supplementary/emulationstation.sh with:

[[ -z "$repo" ]] && repo="https://github.com/RetroPie/EmulationStation"
[[ -z "$branch" ]] && branch="master"

It’s at run-time where you’d get:

lvl0: Error - File type unknown!
emulationstation: /home/osmc/RetroPie-Setup/tmp/build/emulationstation/es-core/src/resources/Font.cpp:17: Font::FontFace::FontFace(ResourceData&&, int): Assertion `!err’ failed.
Aborted

That only needs a package fix needed for our platform, but that’s why we’re gunning for stable, same as everybody else uses.

EDIT: sorry took too long writing that reply. Glad it’s working for you now.
I alternate between the old RetrOSMC launcher, from the Aeon Nox home screen, or a script via an ssh app on my phone. Not sure what’s happening for you there.

My controller is a Gioteck VX-2 Wireless which is working as it did previously. I’ve also run a wireless Xbox360 controller via xboxdrv with no issues. (caveat - just discovered the exit button isn’t working in Reicast to take you back to ES - not sure how long standing that is - but select seems to work everywhere else - researching that now…)

Great, thanks for the detailed reply. I solved the error you mentioned just by copying the resources folder manually as a temp fix.
Only mupen 64 seems to result in a segmentation fault when i run it from retroarch. Other emulators like picodrive and fceu work perfectly fine. Are you using the retropie-setup compiled version for mupen64 yourself?

For what I historically perceived to be performance benefits, I’ve only ever used the standalone version of Mupen64Plus. That should be working fine.
That was one reason I started all of this, rather than waiting for Retroarch to be integrated into Kodi. It kind of snowballed from there.
So, that core is untested and I guess that isn’t working then. Have you found any deal-breaker benefit to using the core over the standalone version?

Not really, other than having global retroarch configuration that would work for mupen (the hotkey to go back to the menu etc of emulationstation would be great). I have been trying your mupen version, but not with much success. It startup freezes when the PS3 controller is connected upfront. If it is connected and connected after starting mupen, it won’t allow pickup any controls unfortunately. I might get back to you in the other thread.
As for retropie, amazing stuff… it works like a charm. I have been testing NES, SNES and Genesis so far :slight_smile:!

For anyone actually reading this particular issue has respectfully moved to:

Greetings all, made some design/code contributions today to RetrOSMC from the outside to bridge your OSMC experience a bit.

New RetrOSMC theme for EmulationStation


New RetrOSMC Launcher add-on with fixes and rebranding:

1 Like

is it based on 0.0009 beta or the former installation?

The only thing related to the installer is the Kodi add-on. I installed from the instructions on the Github repository which wasn’t in it, so I’m not sure.

The installation worked very well, I have two proposals for changes:

  1. after installation edit /home/osmc/RetroPie/scripts/start-emulationstation.sh
    comment out next two lines, otherwise Games with X session will not start such as the simcity and railroad tycoon clones (do not recognize the output terminal):
    tty=$(tty)
    export TTY="{tty:8:1}"

  2. after installation edit /home/osmc/RetroPie/scripts/start-emulationstation.sh
    and add as second line:
    cd /home/osmc

this prevents some problems of the wrong working directory when starting emulation station as described in the thread of the 0.007 installer.

I tried a number of emulators and all works quite smoothly: PSX, PSP, N64, SNES, Dos, Ports, Mame2003…

1 Like