[TESTING] Vero 4K / 4K + video improvements


I don’t believe LE does HDR (they don’t use our kernel).
As @grahamh has stated, the autoswitching option is now deprecated. It will now just work.


Everything seems fine with with either the September update or the October one. I’m sure LE does different stuff, but they’ve never had any issues with HDR—it always “just worked” (I haven’t tested the Vero 4K+ with a non-HDR display, but all my other S905X/S912 boxes running LE tone-map HDR content for those displays as well).

Regardless, I’m a fan of the Vero because it CEC seems to work better than the MINIX or Khadas. If only the UI could be 2160p HDR and switch down to 1080p for HD playback!


Checked this in more detail. LE does indeed send the HDR EOTF in their current kernel but they do not adjust chroma space or bit depth. They aren’t particularly interested in fixing this for the current AML kernel as their focus is on mainline kernel development.

Official LE builds will not do any ‘tone mapping’. @wrxtasy @wrxtasy1 ships OSMC improvements that will indeed do this. But the experience should be identical to OSMC. I suspect you may have ran a community build which has OSMC fixes.

This is possible in Kodi v18.



You’re right! Forgot that I was running community builds on both boxes. Also, just wanna say that you guys are so responsive to questions, it’s really amazing and I appreciate it a ton! :slight_smile: And wow I didn’t realize that was coming to Leia! I’m so excited now!


Yes I personally picked up the @kszaq/vero4K Kernel improvements for my own LE 8.2.4.x onwards and - force Bit depth and Chroma for 4K HDR via the Kodi GUI setting.

Have not seen many complaints at all, I did not try and get to clever auto detecting anything tho. :wink:


Just to update on my banding issues.

I updated from Kernel 119 (which was best for me prior to Oct update as was only one that had no banding) to Oct update.

Pleased to confirm that the banding was NOT re introduced with the Oct update :slightly_smiling_face:

Thanks to Sam and Grahamh for whatever you fixed/introduced in the Oct update !!

One thing I have noticed is that now my receiver is always outputting 10bit, even for 1080P 8-bit SDR files.
Is this expected behaviour ?

here is the log for playback of a 1080p 8-bit SDR file

osmc@VERO4K:~$ cat /sys/class/amhdmitx/amhdmitx0/config
C: 32
VIC: 32 1920x1080p24hz
Colour depth: 10-bit
Colourspace: YUV444
Colour range: limited
YCC colour range: limited
PLL clock: 0xc000029a, Vid clock div 0x000b0000
audio config: on
3D config: off


Yes. We think this the best way to handle things currently.


ok thanks for clarifying. I’ve just tested forcing 8-bit with

echo 4448bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

There was no discernible differences in image quality or colours, So I guess all is good !!


We noticed banding in some situations with 8-bit; but not with 10-bit.
If we pass 10-bit for 8-bit content, it won’t give a visual difference, but it will prevent possibility of banding on some displays.

Hope this makes sense



On my Epson 5030UB I noticed it now days it’s receiving a 10-bit signal. The colours seem just a tad more rich, wasn’t sure if it was placebo or not but the October update does appear to give even my 1080p SD movies a bit more pop.


10-bit files will look better.
8-bit files will look the same :slight_smile:


So it’s placebo :sunny:


Depends what you’re watching :slight_smile:


Blu-ray rips only, re-encoded to HEVC. I don’t have a 4K projector yet (waiting until a good and affordable laser projector is available). Will HDR to SDR conversion be in the next update? Even though I don’t have a 4K projector I’ve started purchasing 4K titles and have them ripped and stored on my server.


There is already HDR -> SDR conversion, but it’s not to everyone’s tastes. There’s a possibility for us to add some curves in the future.



Dont know if anyone noticed but its also using SW decoding for HEVC files on the last working build.


Haven’t seen that here. Please provide a log.


Since the October update resulted in no 4k playback for me, I reverted back to the old kernel (hotfix), where playback works fine.

So now I’ve tried the latest kernel from devel:

3.14.29-127-osmc #1 SMP Sat Nov 10 20:21:10 UTC 2018

but unfortunately 4K playback still doesn’t work for me.

Log: http://paste.osmc.tv/isafoveced

Sometimes I get only black screen (No input signal), sometimes it plays fragments of sound and shows a stuttering picture for a fraction before going to black/no signal again (as in this log).

Hope it works, and happy to test new kernels again (instead of going back to august)…

4k video playback issue after October update

Did some further testing with the kernel mentioned above:

When I remove the receiver from the chain (connect vero4k directly to the projector) 4k also works with the latest kernel.

With August release 4k works with the receiver connected.

Display chain:

Vero4k+ — Denon AVC-X6500H — Sony VW570

Log with receiver connected and no 4k is in the post above.