[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch

You both have right
My TV is little bit old
It was in:
Menu > Settings > Other settings > Oversampling
:slight_smile:
I never change this - it must be Panasonic default, because I already adjusted Kodi to -4% on more TVs
Thanks for your help.

P.S. The Doms script for on the fly changing resolution is very nice.

Jan

I got a new Vero 4K, and I wonder if “sudo apt-get install chromium” is the only thing I need to do to get a browser? Or do I need to do all the stuff that’s been written here over the years?

/Söder

Hi,

Chromium needs X11, so you will need the follow the instuctions above to use it.

There is a kodi addon:

https://kodi.wiki/view/Add-on:Web_Viewer

but is only a text browser.

Thanks Tom.

Hi soder

Tom’s right you need the total install, to get it to run.

If you are running Leila(v.18) you need to change the startup time in x_init.sh to increase the sleep time. Try a sleep 7 insted of sleep 2.

I’m on “default OSMC”, 2018-01, so Kodi v.17

What post exactly is it for me to follow. There seems to be some posts…

Also, is there a OSMC Beta with Kodi v.18?

/Söder

The first post in this thread is the updated instructions

Yes

Thanks. Worked well to install.

I have to get a bluetooth mouse now, since I don’t manage to only use a keyboard for browsing. Also, I had problems starting the browser without a mouse.

But, how do I turn it off, and go back to Kodi? When I picked “turn off”, I thought it only was the X stuff that was going to be turned off, but it was the complete Vero 4K…

/Söder

Based on this you should have a quit option which you then might choose logout

Or you follow the change that @joakim_s suggest one post after that.

Thank you for putting this together. The installer worked and I was able to enter the simple desktop. However, is there a way to return to OSMC (Kodi) without exiting the simple desktop? I would like to keep a desktop version of navigation app running while listening to music playing on Kodi. It would be the best that I could switch between desktop and Kodi back and forth.

In short, the answer is no. Kodi won’t run in widowed mode in x11 ön OSMC. You can install a media player like smplayer or VLC(I think)

1 Like

Excuse my ignorance, but I have to ask: would it be a lot of work to achieve a browser that’s capable of streaming? I’m happy I got your package, but playback of media content only achieves a few fps.

I find it a bit strange that OSMC (and similar projects) seem to to completely neglect streaming, although these days streaming is (at least that’s my impression) the second most common way to enjoy media, after playing back files from a local storage, and much more common than e.g. satellite or cable TV.

I’ve had no luck compileing a browser with hardware-acceleration enabled, dont know if it’s due to the X-windows/driver might be diffrent on rapbian, whom have hardware acceled chromium. Tried their patches and got it to compile but still no hardware accel detected.

Worth mentioning that I’m not a programmer, just a happy amateur.

Thanks for your reply! Maybe I’ll try Raspbian then - If it’s easier to install Kodi in Raspbian than to install a browser in OSMC, this might be the option for me.

Suddenly it stopped working. Is there any log file i can provide?
It just shows the LXDE screen and goes back to kodi.

Does it start LXDE or is it just the splash screen you see?

check /var/log/Xorg.0.log

Only the splash screen im afraid

log : GNU nano 2.7.4 File: /var/log/Xorg.0. - Pastebin.com

looks like that log was cut short, try this from console:

cat /var/log/Xorg.0.log | paste-log

yes ,sorry for that

https://paste.osmc.tv/jikicebovi

it the “keyboard/mouse” new addition from when it worked?

yes i just plugged in for testing it out but i can’t reach to the desktop