[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch


Found out i missed a line in the last time i edited the install_x.sh, the addon syncing, it’s fix now.

To get the addon up and running in kodi:

xbmc-send -a “UpdateLocalAddons”

The error message just shows that there was something wrong with the apt-part of the installer, which i see is chromium and gnome-icons. So re downloading and running the installer might be the best thing.

I’m gonna make some more “logging” for the rest of the installer.

Tho there is no logging now I suggest you try to install it onces more. Download the new install_x.sh, since i edited after your post.


I´m now just installed your script.
All is working fine, only one thing if will be possible adjust somewhere?
For Kodi I have for my Panasonic TV adjusted zoom -4% in kodi setting menu
Kodi is looking good with this setting.
How to apply this setting for you X11 simple desktop?
I have all sides of desktop outside of display.
I know, that basicaly it will be possible adjust in config.txt, but these settings is necessary change, when I switch between HD and FHD TV. Thats I´m asking for some similar way like in kodi.
Thanks for your help.


Did you check there is no overscan settings on your TV?

Shouldn’t need the zoom when overscan off.


Short answer is, it’s a TV problem, on panasonic it would be something like this:

Menu > Picture > Screen Settings > 16:9 Overscan > Off

Else this might be a thread worth checking out: https://www.raspberrypi.org/forums/viewtopic.php?p=305797&sid=4fe5fc284854fe3723841f79ea2c6546#p305797


You both have right
My TV is little bit old
It was in:
Menu > Settings > Other settings > Oversampling
I never change this - it must be Panasonic default, because I already adjusted Kodi to -4% on more TVs
Thanks for your help.

P.S. The Doms script for on the fly changing resolution is very nice.



I got a new Vero 4K, and I wonder if “sudo apt-get install chromium” is the only thing I need to do to get a browser? Or do I need to do all the stuff that’s been written here over the years?




Chromium needs X11, so you will need the follow the instuctions above to use it.

There is a kodi addon:


but is only a text browser.

Thanks Tom.


Hi soder

Tom’s right you need the total install, to get it to run.

If you are running Leila(v.18) you need to change the startup time in x_init.sh to increase the sleep time. Try a sleep 7 insted of sleep 2.


I’m on “default OSMC”, 2018-01, so Kodi v.17

What post exactly is it for me to follow. There seems to be some posts…

Also, is there a OSMC Beta with Kodi v.18?



The first post in this thread is the updated instructions



Thanks. Worked well to install.

I have to get a bluetooth mouse now, since I don’t manage to only use a keyboard for browsing. Also, I had problems starting the browser without a mouse.

But, how do I turn it off, and go back to Kodi? When I picked “turn off”, I thought it only was the X stuff that was going to be turned off, but it was the complete Vero 4K…



Based on this you should have a quit option which you then might choose logout

Or you follow the change that @joakim_s suggest one post after that.


Thank you for putting this together. The installer worked and I was able to enter the simple desktop. However, is there a way to return to OSMC (Kodi) without exiting the simple desktop? I would like to keep a desktop version of navigation app running while listening to music playing on Kodi. It would be the best that I could switch between desktop and Kodi back and forth.


In short, the answer is no. Kodi won’t run in widowed mode in x11 ön OSMC. You can install a media player like smplayer or VLC(I think)


Excuse my ignorance, but I have to ask: would it be a lot of work to achieve a browser that’s capable of streaming? I’m happy I got your package, but playback of media content only achieves a few fps.

I find it a bit strange that OSMC (and similar projects) seem to to completely neglect streaming, although these days streaming is (at least that’s my impression) the second most common way to enjoy media, after playing back files from a local storage, and much more common than e.g. satellite or cable TV.


I’ve had no luck compileing a browser with hardware-acceleration enabled, dont know if it’s due to the X-windows/driver might be diffrent on rapbian, whom have hardware acceled chromium. Tried their patches and got it to compile but still no hardware accel detected.

Worth mentioning that I’m not a programmer, just a happy amateur.


Thanks for your reply! Maybe I’ll try Raspbian then - If it’s easier to install Kodi in Raspbian than to install a browser in OSMC, this might be the option for me.


Suddenly it stopped working. Is there any log file i can provide?
It just shows the LXDE screen and goes back to kodi.


Does it start LXDE or is it just the splash screen you see?

check /var/log/Xorg.0.log


Only the splash screen im afraid

log : https://pastebin.com/wYrnKt64