[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch

looks like that log was cut short, try this from console:

cat /var/log/Xorg.0.log | paste-log

yes ,sorry for that


it the “keyboard/mouse” new addition from when it worked?

yes i just plugged in for testing it out but i can’t reach to the desktop

I think there is some driver issues for that keyboard in Xwindows, it tries to load some drivers but it seems to fail. I’m no expert when it comes to Xwindows and hardware. I’m sorry but i dont think i can help you, Google might be your friend: Debian “model of keyboard” xwindows/x11

I tried without plugging the keyboard in but i have the same results

log : https://paste.osmc.tv/rijavavade

i also tried to increase the sleep commands but nothing changed

Ok, if you’re comfortable with ssh we can try to start Xwidows and see if it gives errors to prompt.

Login via ssh and run these commands:

sudo systemctl stop mediacenter


Yes this worked and i can see the desktop now. Noob question but the launcher wont work again?

Edit : i used this as mentioned above: #!/bin/bash sleep 2 sudo fbi -T 7 -d /dev/fb0 --noverbose /home/osmc/Pictures/Desktop/lxdewallpaper.jpg & sleep 3 sudo su osmc -c "startx" sudo openvt -c 7 -s -f clear sudo systemctl start mediacenter exit

And everything is working

Did you upgrade to Kodi v.18 (Leila) ?

Does you x_init.sh have two “sudo openvt -c 7 -s -f clear” lines? one before and one after startx line?

Whenever I run “startx” from my terminal. It logged in, but, the session itself is different than running it from osmc programs. And why is that?

Are you logged in as another user then osmc? Desktop settings are stored in the user homedirectory.

Installed and running great on March update of krypton, but have to reboot otherwise videos back in Kodi play with audio only.

Which hardware are you using?

Vero 4k

Try this:

in xinit.sh, insert this line before “sudo systemctl start mediacenter”

echo d01068b4 0x3fc0 | sudo tee /sys/kernel/debug/aml_reg/paddr

now it’s been a while might be 0x7fc0 instead of 0x3fc0, you got to try.

1 Like

Will give that a try in the morning, what’s it meant to do?

There is a Alpha swap that changes the alpha channel, that is reverted by those commands. I just dont remember which of them sets the alpha swap and which changes it back.

1 Like

Is it possible to use this version of chromium to get the chrome launcher application working?
When I open chrome launcher I get an error: “chrome not installed”.

No chrome launcher is not for OSMC, since chromium cant run beside Kodi in OSMC. Chromium needs X11, which is started after Kodi closes, and when you exit X11 kodi restarts again. There is no way in the current setup to send links to chromium from Kodi.