[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch

Hello, inside of your script, I saw this,

““sudo apt-get -y install lxde-core xserver-xorg xinit fbi chromium libinput-dev””

I was thinking if I could replace “lxde-core” to different desktop environment like GNOME, PLASMA and MATE?

Well you could, but remember that these are devices with limited memory. I wouldn’t recommend it but try if you want.

1 Like

Okay. Thank you!

Hello everyone
I just installed X11 on my vero4K using this tuto. It is wonderfull.

Do you know how to increase fonts size for all app & desktop ?
Also, how to change mouse cursor size, shape & color ?

Thanks again for this great job.

Hope this helps you abit, run this in commandline:

sudo apt-get install lxappearance

This will install a “Look and feel handler” under Settings

Thanks I will try.
One bigger issue just found out : if I launch X11 then go back to OSMC using logout menu I have black screen when playing any of my Kodi movies / Séries. Only sound is ok, no picture. What is going on?

I’ve noticed it before but i thought it my system since i couldn’t reproduce it easily.

Try this:

nano /home/osmc/x11-start/xinit.sh

Insert this line before “sudo systemctl start mediacenter”

echo d01068b4 0x3fc0 | sudo tee /sys/kernel/debug/aml_reg/paddr

now it’s been a while might be 0x7fc0 instead of 0x3fc0, you got to try.
There is a Alpha swap when X11 starts, that changes the alpha channel, that is reverted by those commands. I just dont remember which of them sets the alpha swap and which changes it back.

OK will try it tonight

Hello, I tried with with both 0x7fc0 or 0x3fc0. It doesn’t work better. Still black screen…

Then I’m abit stumbled. I’ll have to have a look at it. Don’t know if i can reproduce it, been awhile since i used X on my Vero4k. I will get back to you.

Edit: Just tried, but I couldn’t reproduce it, but I’m on Kodi v.18(Leia). Are you using hardware acceleration for those files, Settings -> Player -> Video (under Processing). You have to have Settings Level to Advanced at least. A mediainfo dump of one the offending files could be usefull too.

Is it normal?

osmc@osmc:~$ sudo cat /sys/kernel/debug/aml_reg/paddr
[0xd01068b4] = 0xD47FC0

Will have a look onto acceleration settings.

Now we are stepping out of my comfort-zone, maybe @sam_nazarko can shed some light?

If you are changing to 32bpp mode then yes

Just retried.
I do confirm .

After reboot

sudo cat /sys/kernel/debug/aml_reg/paddr
paddr not initialized

with “echo d01068b4 0x3fc0 | sudo tee /sys/kernel/debug/aml_reg/paddr” and after X launch/closed
sudo cat /sys/kernel/debug/aml_reg/paddr
[0xd01068b4] = 0xF07FC0

with “echo d01068b4 0x7fc0 | sudo tee /sys/kernel/debug/aml_reg/paddr” and after X launch/closed
sudo cat /sys/kernel/debug/aml_reg/paddr
[0xd01068b4] = 0xCE7FC0

Video accel settings are always the same, no change.

Issue reproduced with any of my video library files.
For example

Complete name : /mnt/NASpapa/Airbus A350 la nouvelle star des airs_tvrip1080p-clapapatte.avi
Format : AVI
Format/Info : Audio Video Interleave
File size : 1.44 GiB
Duration : 47 min 10 s
Overall bit rate : 4 378 kb/s
Writing library : VirtualDub build 35491/release

ID : 0
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : H264
Duration : 47 min 10 s
Bit rate : 4 241 kb/s
Width : 1 440 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : MBAFF
Scan type, store method : Interleaved fields
Scan order : Top Field First
Bits/(Pixel*Frame) : 0.109
Stream size : 1.40 GiB (97%)

ID : 1
Format : MPEG Audio
Format version : Version 2
Format profile : Layer 3
Codec ID : 55
Codec ID/Hint : MP3
Duration : 47 min 10 s
Bit rate mode : Constant
Bit rate : 128 kb/s
Channel(s) : 2 channels
Sampling rate : 24.0 kHz
Compression mode : Lossy
Delay relative to video : 80 ms
Stream size : 43.2 MiB (3%)
Alignment : Split accross interleaves
Interleave, duration : 40 ms (1.00 video frame)
Interleave, preload duration : 500 ms
Writing library : LAMELAME_MAJOR_VERSI

Any idea? What can I do?

As I can’t reproduce, i have a hard time comming up with alternative solutions. Will get bck to you when i have something, otherwise the “dirty solution” is to reboot (system->reboot) each time you have run X. But i will investigate further

Thanks. Let me know anything you want me to test.

no news ?

I’m sorry to say, since i can’t reproduce it with Kodi 18. I’m not much of a help, and the mrs wont let me downgrade.

ok, no big deal I can manage.
Maybe when 18 will become official stable the issue will be over for me too