[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch

So no luck with the hardware acceleration Chromium. A pity but I guess the extra Vero hardware and ram should be much better experience than browsing with the pi.

1 Like

Well, as long as we use debians chromium package there will be no acceleration. Which i opted to do instead of compiling my own version and having to maintain it, when I didn’t get HW-accel to work properly

Still looking into HW-accel, but it has been low on priority list. Lots of things IRL that takes time from me.

1 Like

having a hard time starting chromium after latest update of OSMC.

Tried starting it from lxterminal but still no luck :

osmc@osmc:/$ chromium
(chromium:3677): GLib-GIO-CRITICAL **: g_settings_schema_source_lookup: assertion ‘source != NULL’ failed

(chromium:3677): GLib-GIO-CRITICAL **: g_settings_schema_source_lookup: assertion ‘source != NULL’ failed
[3713:3713:0812/173151.069758:ERROR:gl_surface_glx.cc(424)] glxQueryVersion failed
[3713:3713:0812/173151.070230:ERROR:gl_initializer_x11.cc(157)] GLSurfaceGLX::InitializeOneOff failed.
[3713:3713:0812/173151.085542:ERROR:viz_main_impl.cc(201)] Exiting GPU process due to errors during initialization
[3677:3692:0812/173151.099139:ERROR:service_manager_context.cc(250)] Attempting to run unsupported native service: /usr/lib/chromium/content_gpu.service
[3677:3692:0812/173151.124515:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.
[3677:4042:0812/173151.603101:ERROR:object_proxy.cc(616)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
Received signal 11 SEGV_MAPERR 000000000000
#0 0x000001bd2b8c
#1 0x000001b6dd58
#2 0x000001bd2e7e
#3 0x000001bd30c0
#4 0x000072d5afe0
#5 0x000000aaa948
#6 0x000001e10400
#7 0x00000211c9de
#8 0x000002a5775c
#9 0x000002a57828
#10 0x000002a57902
#11 0x000002a57988
#12 0x000002a579ba
#13 0x000001a9a01c
#14 0x000001a9a052
#15 0x00000196f25c
#16 0x000001978620
#17 0x00000197888a
#18 0x000000e95312
#19 0x0000010b7ed6
#20 0x000000e9c2f2
#21 0x000000e9d13e
#22 0x000000e9d32e
#23 0x00000194a166
#24 0x00000194a264
#25 0x00000194f558
#26 0x000001949572
#27 0x00000091d95c ChromeMain
#28 0x000072d4c4aa __libc_start_main
[end of stack trace]
Calling _exit(1). Core file will not be generated.

will check it out, which device are you running it on?

Thanks for the quick response. It’s a Raspberry Pi 2 Model B.

Tested on both pi2 and vero4k, the latest chromium package from debian seems to be crashing. Been looking for bug reports but i cant find any as new as the package is. My suggestion is to downgrade to previous version.

sudo apt-get install chromium=63.0.3239.84-1~deb9u1

1 Like

My chromium is working fine on latest version 68 on rpi3b+. I’m using the unbuntu version from here so not sure if that’s much different from debain version.

probably since it seems to work for you =), but i was hoping to use the debian package so i could make a store package once MyOSMC store v.2.0 comes.

@the_bo, are you setup Ubuntu Mate or Ubuntu Core on your RPi device?

On my device OSMC OS. I setup this tool X11 with Chromium… I’ve launch simple desktop, but run Chromium on it was unsuccessful :frowning:

@feodosij To install the_bo’s version do like this:

wget http://launchpadlibrarian.net/380369885/chromium-codecs-ffmpeg-extra_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
wget http://launchpadlibrarian.net/380369879/chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo dpkg -i chromium-codecs-ffmpeg-extra_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo dpkg -i chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo apt --fix-broken install
sudo dpkg -i chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo apt-get purge chromium

@joakim_s its commands I need to do inside x11 desktop command line? or through osmc command line?

Hi,

You will need issues either with a keyboard attached and exit kodi or via ssh, more details can be found here:

https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks Tom.

@Tom_Doyle and @joakim_s. It works!
Now trying to change resolution on that desktop.

Thank you for your job.

1 Like

Good Job, it works nicely.

It is possible to control mouse using CEC ?

Haven’t tried, and i dont know how to. But i do recommend UnifiedRemote

Hi @joakim_s,

I’ve installed chromium-browser on Vero 4K according to the instructions here.

When I start a browser with any webpage, I get ‘Aw, Snap’ message.
I’ve tried also with Kodi disabled, and the same result.

I can see that chromium-browser starts two instances and the combined CPU load is approx 100% (see picture below)

Any suggestions? Thanks.

It’s ok … I fixed my own problem :slight_smile:

Installed Chromium 50, and it starts up without any errors.

Thanks.
Best regards,
Niall.

Hi there; I had the system up and running on my RBP3 (OSMC as my main system, retro pie as an add-on and X11 launcher as well).

I started getting the “aww snap errors” in chromium noted by others (prior to this it was running wonderfully!); so i re-flashed OSMC. installed retropie, installed my vpn etc…

However, now when i use the installer above the entire system “freezes” at the main selection screen on OSMC - i’m unable to use mouse or keyboard or xbox controller.
I can sometimes SSH into the system but i really only know how to follow other people’s instructions and I’m not very adept at linux.

wondering if you knew what was going on or if others had experienced this? should i use the installer and prior to a “sudo reboot” run the sudo apt-get install chromium=63.0.3239.84-1~deb9u1 instead?

if I don’t use the X11 installer everything runs fine on my system… so it appears its the act of installing that is causing some crash/freeze?

Any thoughts would be great! :slight_smile:

@MattGee I will do a clean install either tonight or tomorrow and try out the installer again and get back to you.

1 Like

yeap there seems to been some changes in the debian dependencies. To solve it here is what you do:

sudo systemctl disable lightdm

don’t know why lightdm suddenly is running from start, it never used to. will ahve to look at the installer again. Thanks for telling me, and chromium version isn’t longer in repository. So we are out of a webbrowser unless you use the one from ubuntu