[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch


Click in to Settings->Add-on browser->My Add-ons->Program Add-ons->X11-launcher->Enable

Under Programs, you will now have another icon beside My OSMC



Hi guys I read a similar thread before this looks newer and like u have fixed more issues Sam pointed me this way and said to ask I have a Vero 4k he said you might have a specific build I have only scrolled through quick but I’m sure it’s not what I have tried before I will try when I’m off next Wednesday or Sunday night but you I don’t want no media player for a few days if I clart anything so yeah if you have anything specific can u send it this way thanks for all the work you have allready done


@mulethomas Sent you a PM with instructions how to get X running on Vero4k, good luck

Edit: updated first post with Vero4K instructions


Thank you


Hi guys my desktop is running fine thanks for that I’m just wondering is there anyway to open a terminal from the desktop? I have downloaded some emulators for the rom manager addon but would like to test them from the desktop to check the compatability with my vero AS I’ve been having trouble with the rom manager thanks


As mentioned earlier in this thread you got to install a terminal-software, like xterm.

sudo apt-get install xterm

After that when you restart your X-desktop, you should have a Xterm icon under SystemTools, which gives you a terminal. I’m unsure if you need to restart X-desktop, but i know it will be there if you do.


Awesome thanks mate I did a scroll through should have searched though my bad


wow its great! but when i try to play a video in chromium it really laggs.


Because there is no accelartion at all, I was tryinbg to compile an OSMC-chromium with accelration but i had a hardtime and got other projects. Will revisit soonish.


Brother, your installer works like a charm! THANK YOU!!



Hi Joakim,
I am a little lost now.

I managed to install now via sh ./install_x11.sh
enabled the x11 launcher.

But how can I switch now between kodi and chromium?

Can I play DRM content from Amazon prime via input stream?
Still saying that there I need an alternative configurtion for input stream. -> valid when using kodi and Amazon Prime VOD addon from sandman.

I was confused because after launching x11 my vnc connection was lost.

I now managed to start chromium. but can not access via vnc or remote to control the raspberry.
Is vnc still possible?

will check now playing netflix and prime content…

Thanks Thomas


Under programs there should be a new icon, start that and kodi will shutdown and Desktop will open up.

To play premium contentent you should use kodi.v18 (gmc nightlys)

In post 123 in this thread you get the solution for having vnc enabled when exiting kodi. Search vnc in this thread and the reply i wrote should apply to you.

If you got any other questions, just throw them at me :wink:


Hi Joakim, thanks, VNC running again.:slight_smile:

is it possible to install widevineCDM?

I also have another OSMC where I tried to upgrade to 18.1 nightly, but this failed…

so still struggling to play DRM content.

Even I could not manage it on a rpi with stretch and chromium , there I got the problem widevine can not be updated…

I know a little of topic…but maybe you know.

this is driving me crazy

thanks Thomas


@riker1 I understand your frustration, i have struggled with chromium my self. If you want DRM content it’s v.18 and thats the way. Even if we managed to get widevine running, you would have no hardware accelration in chromeium, and the video would stutter/lag very much.

Been working slowly to get a version of Chromium for OSMC with accelration, but i’m not getting good results.


ok thanks


I do not see X11-launcher under Settings->Add-on browser->My Add-ons->Program Add-ons. The install appeared to go fine. I tried rebooting, no help.


Okey let’s check if the zip got unziped. Do you have a folder called x11-start in osmc homefolder ?

If not, do you have a install_x11.zip in osmc homefolder?


My bad, working now. I was already sudo’d to root when I ran the installer. Understandably, it does not like that. Possibly a UID check at the top of the install script would help protect me against myself.


Thanks for the suggestion, added a check for current user being osmc, before the scripts starts installing


Just installed on Vero 4K using install and the extra step to enable the vero 4k driver.

When I start X11 the background is black, the mouse pointer is black, and all of the text is pretty fuzzy and very hard to read. I am pretty much unable to make any setting changes because I can’t see anything.

Any idea of what might be causing this? Can I change the background or mouse pointer or text colors without using the gui, so that I can use the desktop?

Thanks for your help.