[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch

I had a transition video playing but it was not very robust so people had problems. If the timing was a bit off (different rpi versions, SDcard speeds etc.), the display would not be intialized correctly and emulationstation would crash.
So I decided against it.

I’ve also wondered why retropie is so quick to start,my scripts are based on what mcobit had done with retrosmc. But i think emulationstations binary grabs the framebuffer before kodi closes completly and throws up that start emulationstation picture. I will try a few things to get a splash up, but i’m not having high hopes.

Thx for this !!! I just installed it. Worked fine…
Gonna try it tonite, when I got some free time. Cheerz.

11 posts were merged into an existing topic: Help Installing Wine

Has anyone tried this with the OSMC testing Kodi v17 Beta5 ?
I’m looking into attempting to getting mame running on the Vero 2, and since it requires x11, I’m thinking @joakim_s project may be a good combo.


I wanted to use this to watch Amazon Prime videos, but it says it requires the latest version of chrome browser, is there a simple way to update it?


You can just use Kodi v17 and Widevine libraries

Yep, I tried but I didn’the find any addon for Amazon prime for my country (spain). Only UK, DE, and US are available.

So, at the moment updating chrome would be my only option…

How can I uninstall this after using your installer? I didn’t read the bit about pi2 (oops) and installed it on a pi1.

It’s not worth the work trying to uninstall every package and dependecy for X-server, since you got to do it by hand right now, will have a stab at makeing an uninstall script, when time permits. So my thought for you is to do a clean install if your system has beconme unstable/unusable.

It’s fine, OSMC isn’t unstable or anything, the desktop environment just doesn’t work.

Hey @joakim_s ! Thank you for this addon, real good work here!

I just have a little problem: on my RPi 3B when I launch the program to launch x11, Kodi freezes (I don’t know if it’s normal or not) and then OSMC blackscreens. SSH still works and sudo reboot now take like 3 minutes or so to make Kodi appear…

I read every message of this thread so I tried to go in the x_init.sh and the xstart.sh but the structure isn’t like @the_bo’s when he had a blackscreen problem…

Any idea how to fix this?


Are you running Krypton ? (else the sleep command in the scripts needs to be increased.)

Kodi is supposed to “freeze” for a few seconds(depending on how many/which addons are installed) then quit, after that X windows is supposed to start after about 12-30 seconds (you are supposed to get a splash screen there, which is followed by a few more seconds of black screen)

I suggest you play with the sleep commands in /home/osmc/x11-start/x_init.sh
first sleep set to 5-10, second to 3-5.

Hope that helps

Errr… No idea, I suppose I have the lasted version since I installed OSMC yesterday!

It did the trick! Thank you very much! :slight_smile:

Is this project still up and running?

Tried to install it today on an updated OSMC on RPi 2, i only get a black screen :frowning:
I have tried to edit the sleep time (first: 10sec, second: 5sec) but no sucess.

Is there any errorlogs or other ways to troubleshoot this?

I only need the desktop and browser one time to authorize the alexa java client for RPi.

Well try to increase the first sleep even more, we have had ppl needing as much as 45 secs to get it working. I did updated it earlier to the faster shutdown times of the Krypton RC’s, it’s all dependant on number plugins, how much time it takes to close down kodi.

1 Like

Got it working with current setup after 5 reboots, dont know what the problem was but atleast its working :slight_smile:

Another question, is it possible to open terminal from the desktop?

I need to do Step 7 (terminal2) in this “how to” to get Alexa wotking on my OSMC

in ssh:

sudo apt-get install xterm

After that you should be able to start it via “Run” in start menu. xterm

next time you start the desktop, you got xterm under startmenu/System tools/xterm

Hi @joakim_s

How do I update this when I move to krypton?

Will all my installed applications settings be deleted during update. Chromium bookmarks vlc player etc.

Oh thanks for message about making a uninstaller for this only seeing the message now.

Thanks for adding splash screen also looking forward to krypton. So with krypton will we be able to close kodi much quicke when launching x11?

Keep up great work.

Hi @the_bo

First thing the only thing needed to update should be trimming the sleep times. Might have to enable the plugin in Krypton, dont know how the upgrade will work with installed addons.

As I understod it, Krypton upgrade will just be a “normal monthly upgrade”. Which would mean that it would not remove none “OSMC” things from the system. So your Xwindows and apps shouldn’t be affected. But I’ve never regretted doing a back up :grin:. On a clean Krypton install you just run my installer and enable the launcher-addon.

On Krypton RC I’ve got the sleep time down to about 3 secs from clicking launch in kodi till i get the splashscreen. But still I run a really clean install just a few addons, like youtube, swedish public domain TV, Internet radio player