[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch

How do I enable the splash screen? Do I have to run your installer again or can it be enabled manually incase the installer overwrites my x11 desktop.

Kodi closing in 3 secs that be awesome some difference from my current 45sec :slight_smile:

Might install krypton rc on a spare SD card test the sleep time.

Thanks again

There is a sleep time of 3secs for kodi to close, then an img-viewer showing a picture for 3 sec then Xwindows starts(black screen for about 6 secs on my pi3). It’s just shows the splash image as soon as kodi closes, and you have to find the right sleep time again.

You could download the zip file from my github page , disect the script in you desktop and make the needed changes in your start files on your pi.

Hi I wanna thank you for creating this script which makes it easier for lots of people but I have faced lots of issues.
First of all I should say that the link you put in the script is no longer available. 404 not found for chromium browser file itself. Well that doesn’t matter because we can easily find the file in the web.

So I searched the specific version but it was deleted so I had to get the latest version which is 53 for trusty armhf ( I think I found it on launchpad)

I tried to install it manually. (Not with the script so I just ran dpkg for installing chromium 53 and codecs and the libgcrypt )
The simple command didn’t work so tried with apt-get --force -yes… bla bla bla
I couldn’t install chromium file itself because it says that the libjpeg8 package ( one of the dependencies) is not installable. It seems that this package is no longer available for Debian Jessie . What should I do?
I read somewhere that I can install it via Debian testing repository. I don’t know it works or not.

And another issue. How can I enable the addon? I even updated the local addons but there is still no such addon. That’s why I should exit kodi and startx to enter lxde every time.
I hope you can help me :slight_smile:

When did you run the script? Was it an old version of the install script(there has been quite a few updates since the last months)?

I ran it yesterday and it’s chromium 51 it installs. So it’s hard for me to diagnose your problem, i just checked the link in the script and the chromium 51 download still exist.

Hey sorry I didn’t have network to reply. Well I just retried to install version 51 and it worked! Maybe I missed some letters in commands…
Anyway why shouldn’t version 53 work? If the package that I sayed before is no longer available for Debian so we can never install newer chrome versions :frowning:

Guys is this krypton version stable? There is a notification on my kodi but I can’t find the update anywhere. Even the updater in ((my osmc)) says no updates available :neutral_face:

About version 53, when i find a version that doesn’t have dependecies that isn’t filled by OSMC then i will update the script with a new version.

When it comes to Krypton i found it rock solid, even converted me from Confluence to OSMC-skin- Strange since the update has been out for OSMC now for 24h at least. Try this in ssh:

sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

Just installed this,but i think i need to resize ,because i can’t see anything apart from Chromium and My folder Shortcut. Can you please guide me on how to do that?

To be honest there isn’t much more then Chromium and filemanager installed, not even a terminal. But you should be able to install almost any app that is in the debian repository.

My suggestion is this:

nano ~/x11-start/x_init.sh

insert this lines:

sudo su root -c “fbset -xres 1280”
sudo su root -c “fbset -yres 720”
sudo su root -c “fbset -vxres 1280”
sudo su root -c “fbset -vyres 720”

before startx line.

Sorry for the dumb question but if i want to quit this program? What should i do? reboot from terminal?

In the lower left corner you have an arrow (it’s the symbol for a “startmenu”). click on it and chose log out, then logout again.

If logout twice is a bother, there is a hack earlier in the thread that if you logout you get kodi again, with out confirmation

Yes this is what I was looking for when I told you that I don’t see anything apart from Chromium and my folder shortcut… Something is wrong with my resolution I suppose. Tried what you posted,but only made icons/fonts bigger. No lower left corner arrow…

sounds like an overscan problem, do you see the bottom bar at all?

Well to help you for the moment try this key combination “CTRL+ESC”, that should bring up the menu, arrow up and enter should bring up a logout question in the middle of the screen

CTRL + ESC works ,however no bottom bar at all. Is there a workaround for this overscan problem?

Try other aspect ratios in your TV’s settings.

Thank you very much

Awesome work @joakim_s.

Krypton now boots to desktop in under 10 secs :slight_smile:

Keep up great work

controlling the X11 desktop using smartphone, instead of keyboard and mouse
So this is what I succeeded in doing:
I downloaded the portable archive of UnifiedRemote from here:

(Perhaps it would have been possible to download a different release, I was not able to install the raspberry pi deb file from there, so I opted for the portable version instead).
Then -
tar -xvzf urserver-

Of course, installed the UnifiedRemote android app. There’s other client apps, that’s what I’ve been using.

Then, cd to the folder where the UnifiedRemote was extracted and run it…

And that’s it, the server is running and the mobile device can control mouse and keyboard movements and presses on the desktop. Works great!

The only issue I’ve been having, perhaps someone can assist, I was unable to include the urserver in the boot sequence, to load automatically whenever the desktop is loaded, and to stop when it is logged out of. Any suggestions?

So you want it only running while xwindows is running? Not from boot?

then this is my suggestion

sudo apt-get install screen

nano /home/osmc/x11-start/x_init.sh

here is how it should look to get it running aslong as x11 is running.

sleep 2
sudo fbi -T 7 -d /dev/fb0 --noverbose /home/osmc/.kodi/addons//plugin.program.x11-launcher/fanart.jpg &
screen -dmS Urserver /home/osmc/urserver-
sleep 3
sudo su osmc -c "startx"
sudo openvt -c 7 -s -f clear
screen -S Urserver -p 0 -X stuff "exit$(printf \\r)"
sudo systemctl start mediacenter

observe line 4 and 8 is new

Great solution just had to buy the app and installl on my pi’s

Thanks! Worked great!
That’s exactly what I wanted. We could have included the service for the entire OSMC boot, but for Kodi I prefer to use Kore, which is a great app and more functional, and I prefer to use UnifiedRemote just for the keyboard and mouse emulation on the desktop. So thanks!