Tethering from wired to wifi not working in latest version

I came from alpha 4 and failed to get tethering working on there. Then I installed the clean RC and did the last update scan about 3 minutes ago. Rebooted and everything seems fine.
Now I try doing tethering again but it still doesn’t work… I tried doing it from the GUI this time, but I get the error message

Error enabling hotspot - see log for details

When trieing via SSH I get

Error enabling wifi tethering: Not supported

Without this **** connman (sorry but this has only caused problems for me over the standard linux networking) it works flawless (tested on raspbian)!

Here is dmesg from my Wifi Stick (I tried tethering when plugged in directly into the pi and into a self-powered hub)

[    2.973185] usb 1-1.5.2: Product: 802.11n WLAN Adapter
[    2.973202] usb 1-1.5.2: Manufacturer: Realtek
[    2.973217] usb 1-1.5.2: SerialNumber: 00e04c000001
[    3.062101] usb 1-1.5.4: new high-speed USB device number 6 using dwc_otg
[    3.172622] usb 1-1.5.4: New USB device found, idVendor=13fd, idProduct=1840
[    3.172656] usb 1-1.5.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3

Thanks in advance for your help!

What driver is loading for the adaptor ? (Check dmesg)

If it’s rtl8192cu then we are aware that this driver is not currently supporting tethering under OSMC.

It’s on our todo list to fix this. The problem is nothing to do with connman, simply that host AP mode support is not compiled into the driver.

This driver is listed in dmesg:

I also get a bunch of this messages:

usb_read_port_complete()-1284: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)

Is the driver powered with a hub? If not, have you tried enabling max_USB_current?

When I did dmesg it was plugged in directly to the pi without a hub. How do I activate max_usb_current? And when I do, should it be plugged in to the selfpowered hub or to the pi directly?

Using a powered hub max_usb_current is not necessary. If you aren’t using a hub, it can be activated in the pi config options in MyOSMC followed by a reboot.

I am getting these Errors in both ways, so I guess it’s what DBMandrake said…

Yes, please!

See Cannot enable tethering - #2 by DBMandrake

it’s not going to be an easy fix



really appreciate your work so no pressure from here :wink:

Not sure if this is any help, but it worked for me for some older version of osmc that were already using connmanctl following this:
and this:

But unfortunately, after updating, it didn’t work anymore.