Tethering issues - password and connect


I have 2 issues with thethering.
My device is a rt2800usb. On my old system (xbian) it works fine as access point via hostapd.

In OSMC we have this fine menu to configure it…
But here, I can’t change the password. Every time I change the password it switches back to the default one.
I also tried change the password in /var/lib/connman/settings with the same result, it switches back to default.
How can I change the password?

Second… this is maybe a bit offtopic.
I can connect the wifi with all my Android devices. Thats all fine.
But I have a problem with my laptop (openSuse13.2/KDE/networkmanager).
Connection is fine but i can’t get out to the internet.
I can ping my router and the tethering access point too.
Any ideas?

Best regards corax

I get it!

I had to change /etc/connman.prefs.


Now the Laptop can connect without problems.

The password is changeable if you enable tethering directly after the password change. Don’t go back or anything else.

1 Like