Tethering not possible?

[Reposted from previous comment made on a RP thread…]

New user, installed Latest (2017-01.1 USB for Apple TV), and got things all working, and decided I wanted to enable wifi->ethernet bridging (so my wifi would be shared onto the ethernet, allowing me to plug things into the ethernet…

discovered that br_netfilter module doesn’t exist, and that seems to be the major problem causing all of the rest:
connman complains “Error enabling ethernet tethering: Not supported”
which the log says “osmc connmand[1337]: Missing support for 802.1d ethernet bridging”
which looking at the code is due to
if (stat(BRIDGE_PROC_DIR, &st) < 0) {
connman_error(“Missing support for 802.1d ethernet bridging”);
return NULL;

BRIDGE_PROC_DIR is /proc/sys/net/bridge
which doesn’t exist… so that means it’s a module… and behold it’s br_netfilter… and we don’t have it on the box.
osmc@osmc:/$ sudo modprobe br_netfilter
modprobe: FATAL: Module br_netfilter not found.

Not built with/into the current kernel?

I can now confirm that this is the problem (or at least the major one)

using the instructions at Compile Kernel on RPI2 from RBP2-sources-osmc - #2 by DBMandrake
I built a new kernel using 4.2.3 (I tried the -23 version in jessie-devel, also was missing br_netfiilter)
and changed the config to add br_netfiilter (and other potentially needed modules, just in case)

A few reboots, to get the new kernel into place as the booting one, and I did a modprobe br_netfilter, and behold tethering is working… I did have to manually set up a box I plugged in, but once I got that box configured with IP/gateway/DNS/etc, it worked great… it was able to access my network and the internet, via the wireless connection on the ATV.

So, can this PLEASE be fixed for the next image (or kernel update?) release? Right now, it’s certainly broken on the ATV, it is likely broken on the RP (based on the post I link to above), unsure of where else. OSMC offers tethering, so this is an actual broken feature, not a new request.

I am not aware of issues on Pi, but you can check the kernel.
Please submit a pull request according to OSMC’s development guidelines (see Wiki) and I will accept it.

Hey Guys. I just installed the last version of OSMC for RP4 and it’s great. congratulations.
Unfortunately, when I tried to run a Docker container (using swarm/stack. not related to tethering/AppleTV) I got a error message that the module br_netfilter is not loaded (same problem on this thread so maybe it’s related).

I tried to compile a new kernel for it (5.10.78) but the module is not there as well. I’m trying a newer kernel (5.14.16) but I have little hope.
Anyone can help me get this module up and running.

I’m not sure why you resurrected a 5 year old thread who’s title and platform subforum is seemingly unrelated to the topic for which you are questioning but, there are already a couple of threads that address this docker issue. A forum search should reveal them.


Hello ActionA
Thanks for the much needed slap on the face. I was so focused on fixing (br_netfilter) the problem that I forgot to look for a solution (make docker running on OSMC with swarm support).
I did search the forums with no success for my problem. I’ll look for a better (or even new) thread to post my problem.

If this thread does not resolve your issue, you should start your own relevantly titled thread with useful debug info.

Let me know the CONFIG_ options you need – if it’s only br_netfilter I can add this.
Otherwise submit a PR against OSMC Git. This will save you rebuilding on each kernel change



Tnx for your offer Sam.
Unfortunately recompiling the Kernel did not work. Maybe I’m missing something.
'm new to OSMC and to kernel building. I visit the post ActionA pointed to me. On my installation Docker is working when starting a standalone container. And I can make it work like this. But my previous installations (running vanilla Debian) I was using the services/stack method to boot a system with connected containers. when firing this up I got this message:

 "error creating external connectivity network: cannot restrict inter-container communication: please ensure that br_netfilter kernel module is loaded"   

Prior to this message I didn’t even know I need this module, so I’m afraid I might not be able to answer your question