Tethering on Pi2 - getting "Error enabling wifi tethering: Permission denied"

hi folks,

have read a few threads on tethering and it appears it should work under RC4 and above? I am running the following command as per a few other threads. i checked and config appears to be written to the connman.conf too

osmc@osmc:~$ sudo connmanctl tether wifi on OSMC mypassword
Wifi SSID set
Wifi passphrase set
Error enabling wifi tethering: Permission denied

not sure why? this adapter worked fine no issues under raspbmc with the hostapd hack.
osmc@osmc:~$ lsusb

Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 004: ID 1997:1221
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Any ideas what might be causing the issue the perm issue?

thanks in advance.


Have you tried using the GI to configure this as it was designed?

hi ActionA,

thanks for the speedy reply.

i did try and configure it under the osmc --> network settings, but i couldnt see anywhere that looked like i could enable tethering and in which interface order.

I also had a look /search in the osmc wiki and couldnt see tethering mentioned anywhere. is there any doco you could point me too? or any pointers on what to look for?

thanks mate.

Is your OSMC install up to date ? If you have both an Ethernet and Wifi connection you will get a Tethering option appearing in networking below Wireless.

If you don’t you are probably running an old version of OSMC, so use the updater to bring it up to date.

hi guys, thanks…

i rebuilt it on the latest image and its working fine ;c)


thanks :c)