Tethering provides no IP address to wireless devices

I am running the latest version (I think, I’m not sure where to confirm that?) and I have set my IP address to manual, turned on Wireless device and configured tethering ethernet to wifi.

The hotspot is created and I can connect with my phone but it has no connection, and looking at the wifi settings on the phone it shows the IP is not available. I have tried to search for which DHCP server that OSMC uses but I can’t find anything. Is the DHCP provided by connman? I am new to connman and don’t know how or where to change the settings for some things but I am comfortable using the terminal via ssh.

It would also be nice to change the allocated IP’s of the tether, at the moment in ifconfig it shows my tether as and I’d rather have this set to or similar to identify this traffic for iptables, at the moment it sometimes changes the 3 in that address to a 1 or a 2.

I also ran into another problem before where connman doesn’t seem to get internet connection via ethernet. I fixed this by putting a sleep 30 and service connman restart into the startup script, not ideal but it works now but just curious if the problems are connected?

Any help would be appreciated, I am happy to provide logs and config settings if required.

When tethering is enabled, connman provides a DHCP server of its own for the tethering clients. The IP range it allocates is not configurable.

At the moment there is a known issue with DNS in Tethering mode - you will need to set dnsproxy=yes in /etc/connman.prefs to be able to use Tethering.

Can’t think of anything off hand that would cause you to have to restart connman to get a working Ethernet connection - sounds like an issue with your Ethernet network. Is there anything unusual about it ?

Thank you, setting the dnsproxy to yes worked for the tethering. I now finally have a working WiFi hotspot.
It’s a shame there is no way to configure the DHCP server connman uses, is there any documentation to show which ranges it does use? Can I reliably target the traffic on 192.168.X.1-255 where X is not 0?

I will also try to remove the sleep in the startup script now the DNS is working to see if they were related.
Thanks again

Were you able to change the default DHCP address pool for the tether?