Tethering using TP-WN725N v2

The v2 of this wifi dongle has always been difficult to get running on a Raspberry Pi. However, at the moment, it should be supported by the kernel. I used to use raspbmc and installed a custom hostapd and a driver that I compiled myself. This works like a charm.

Every update broke the driver but using the script, it wasn’t too hard to re-compile and be up and running in no-time.

Then, OSMC was introduced. I tried the very first version but didn’t get the hostapd running. Today, I installed RC3 and saw there’s a tether function availabe from the gui! So I tried immediately: I enabled the wifi (which worked), then I enabled the tethering (ethernet to wifi) but that fails every time.

From the commandline, I executed connmanctl tether wifi on osmc passwddddd but got the error

connmanctl> tether wifi on osmc passwddddd
Wifi SSID set
Wifi passphrase set
Error enabling wifi tethering: Not supported

So now I’m lost. What can I do to make this work?
On a trip/vacation, I’m used to take the raspbmc box with me, preloaded with some movied (mostly childrens movies to get the children asleep abroad :smile:) which I can control using my phone and without the requirement for any other network being available.

I’d like to use osmc but this is keeping me from using it full-time (only at home where I connect it using ethernet)

Check with dmesg to see which driver your adaptor is using - not all of the drivers currently support hostap mode - for example the rtl8192cu driver we are using currently isn’t supporting hostap (tethering) mode. We hope to get this fixed at some point but isn’t easy or we would have done it already.

I understand completely.
I have a hard time figuring out the driver from dmesg. I’m biased (assuming r8188eu) and I can see this message:

r8188eu: module is from the staging directory, the quality is unknown, you have been warned

which is confirmed by lsmod:

Module                  Size  Used by
bridge                109478  0 
cfg80211              498170  0 
rfkill                 25348  2 cfg80211
8021q                  21600  0 
garp                    7671  1 8021q
stp                     2094  2 garp,bridge
llc                     5806  3 stp,garp,bridge
nfsd                  316748  2 
r8188eu               537312  0 
uio_pdrv_genirq         3642  0 
uio                     9968  1 uio_pdrv_genirq
fuse                  105811  1 
ipv6                  410526  41 bridge

However, the lines I see in dmesg are these (and I’m confused because they don’t mention the r8188eu driver)

[    2.284052] smsc95xx v1.0.4
[    2.362160] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-bcm2708_usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:91:c0:3d
[    2.440580] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    2.541216] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=8179
[    2.541260] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.541278] usb 1-1.2: Product: 802.11n NIC    
[    2.541294] usb 1-1.2: Manufacturer: Realtek
[    2.541310] usb 1-1.2: SerialNumber: 00E04C0001

Now that osmc is stable, can you please tell me whether you were able to solve this issue?

It is still on our todo list but it is not solved yet.