Tethering

Installed latest OSMC(18.5) on pi3 model B+. Bluetooth headset works fine as long as wireless is not enabled. Lot of stutter with tethering or wi-fi connection on 2.4 Ghz band. As model b+ supports 5 GHZ, is there a way to create the Tethering connection on 5 Ghz band so that it does not interfere with the 2.4 Ghz bluetooth band ?

How to switch to 5 Ghz band - both for wireless and tethering as the GUI does not provide the option ? I want to primarily use Bluetooth headset AND tethering (for connecting android phone to OSMC hotspot(via tethering) and using Kore/Yatse app on phone to control OSMC.

CLI commands to switch to 5 Ghz will be helpful.

Only 2.4Ghz is supported currently. This is to support as many devices as possible.

You might have success using hostapd, instead of the built-in tethering. See https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md That should allow you to specify the hw_mode

Understood.

Good suggestion. Will try this out and check if Bluetooth interference stops. However, this approach adds another layer of complex configuration and renders the in-built tethering redundant.

Request the developers to look at a parameter similar to hw_mode that can be tweaked in in-built tethering config files - that would be a straight forward solution.

Anyway, thanks for this approach - will try it out and hopefully it should resolve the BT interference problem.

1 Like

Just thinking aloud and not sure if I am on the right track but would Wi-Fi Direct feature on 5Ghz be a possible work around ?

I don’t know how you’d configure that.