Texture Cache Maintenance utility

Hello I’m haveing a permissions issue running the utility. I have a clean RC installed on pi2. I have downloaded the utillity by using

wget https://raw.github.com/MilhouseVH/texturecache.py/master/texturecache.py
chmod +x ./texturecache.py 

I have confirmed that the file is in the /home/osmc forlder. I have created the script texturecache.cfg

 sep = |
userdata = ~/.kodi/userdata
dbfile = Database/Textures13.db
thumbnails = Thumbnails
xbmc.host = localhost
webserver.port = 8080
webserver.username =
webserver.password =
rpc.port = 9090
download.threads = 2
extrajson.albums =
extrajson.artists =
extrajson.songs =
extrajson.movies =
extrajson.sets =
extrajson.tvshows.tvshow =
extrajson.tvshows.season =
extrajson.tvshows.episode =
qaperiod = 30
qa.file = no
qa.fail.urls = image://video, image://music
qa.warn.urls =
cache.castthumb = no
cache.hideallitems = no
cache.ignore.types = image://video
logfile =
logfile.verbose = no
checkupdate = yes
lastrunfile =
orphan.limit.check = yes
nonmedia.filetypes =
watched.overwrite = no
network.mac =

I confirmed the script is in /home/osmc forlder. I have set the webserver to port 8080 and do not have a username or password enabled.

When I try and run

./texturecache.py P

I get

-bash: ./texturecache.py: Permission denied

I’m I missing a command? I’m at best a novice at this on a good day. This worked fine on raspbmc.

Thank you for any help


Have you tried sudo?

sudo python texturecache.py P

Ok thank you both,

sudo python texturecache.py P