Thumbnail creation error on pictures and home videos

Good day team, thanks for having me. I hope you may be able to help with an error I’m seeing, I can’t find anything similar in the search but if this has been asked and answered before please send a link and I’ll go dig it out.

I have a Vero 4k+ connected to my LAN via ethernet which my Synology NAS is also connected.

My NAS is where all my films, pictures and Home Videos are stored and so far, I’m blown away by this magical little box which has made viewing my content on my TV absolutely incredible.

The issue I am having is with the thumbnails of my own personal content (pictures and home videos). One or two pictures and around half of the home videos thumbnails show as horizontal lines.

I have tried deleting the two database files and rebuilding the thumbnail data but it is still the same. Strangely though, initially the photo thumbnails do work after a rebuild but when I exit the menu and return, the same ones are again broken.

Any ideas?


As it only happens with some files I wonder if it’s a codec issue.
Could you get us some MediaInfo output so we can see how the file is encoded?


Tha is for the reply Sam. Can you give me an idiot’s guide of how to exactly get the info you need?

Download the MediaInfo program here: MediaInfo, select an affected file and copy and paste all of the text output here.

This is the 2015 photo thumbnail

This is a home video.

@sam_nazarko, small progress with some more information…

With regards to the photos folder, as there are folders within the year folder, the way I get Synology and therefore the Vero to show a thumbnail is by having a single photo from that year alone in the folder so that gets chosen as the thumbnail. By trying some different pictures, I have managed to find ones that don’t show the error so I definitely think it’s something to do with the picture file itself.

Could it be that it’s too big for the Vero 4K+?

Any ideas @sam_nazarko ?

Same problem for me. My photos/videos are on a Synology NAS, and my corrupted thumbnails even look the same(!). I’m on a recent Vero 4K+ with latest updates.

For info I have a number of Raspi running an older version of OSMC (compiled 26.11.20 running Kodi 18.9) which do not have this problem.

Details of a problem picture:

Sorry for the late reply – it’s been a bit busy.

I’m thinking of an idea to reproduce the problem and solve it.

My understanding is that the problem is that you get a defective thumbnail generated from your video if you have automatic generation of thumbnails enabled and simply navigate to the directory containing the file.

  • Does this happen when only a directory with one file is active and only this directory is selected first after a first boot (want to ensure there is no previous thumbnail generation activity interfering)?
  • Is my assumption above on how to reproduce the issue correct (navigate to directory)? If so – could you provide a non-personal / private video (could be of the floor or a newspaper or anything as long as it can reproduce the problem) that we could use to reproduce the problem.

The only thing that immediately sticks out via your MediaInfo output is that the frame rate is variable. This could be problematic for thumbnail generation with Kodi.

Lastly – I don’t suppose you use Kodi on another platform and have seen if you could reproduce the issue there as well?



Hi Sam,
No need to apologise, just having you reply to messages and genuinely looking into issues is just fantastic customer support.

I’ll attach a couple of videos if possible and I believe I’ve done what you asked. I’ve taken a new video, put it in its own folder and looked at it after a reboot. The issue is still there.

Secondly. This has also happened on photos too. Although I can find photos for thumbnails that it doesn’t happen to, if left to its own devices, the thumbnails that the system picks, can also have the issue.

How do I share videos with you? The upload button doesn’t accept video files.

I’ve PM’d you an upload link which will let you drag and drop some affected files. Is it OK if I share this with the team so we can look in to this more effectively?



Excellent thank you.


Has there been any progress on this issue from the team?

Can you confirm that I can share the uploaded files?

Absolutely, feel free.


Hi Sam, happy new year! Just curious to see if there has been any progress?


This won’t likely be fixed for Kodi v19.5 which we will release shortly; but we’ll aim to have it solved in the Kodi v20 release which uses a newer version of ffmpeg.



Installed latest OSMC update (to Kodi V20), and issue is still present as before. Can I help with logs, screen shots or problem pictures?

Have you cleared the library to ensure the thumbs are being generated by the new version of Kodi?

Hi Sam,

Good to hear from you. I’ve just done a full reset and delete of the thumbnails folder and rebuild.

Unfortunately the issue is still present.