Thumbnail generation often fails and freezes system

Continuing the discussion from April update causes System freezes:

I do not think the thread went much disjoint, as most people reported the same thing, but here you go again:

Install the Samba server from the app store.
Browse quickly through a list with thumbnail images (such as movie library, pictures, streaming addons…)
Thumbnails stop loading, sound stops working aka freeze

Uninstall samba server: everything is working again.

UPDATE this also happened to me now without having the smb server installed So I changed the title accordingly…

And if you never install the Samba Server, what happens?

Can you post a log post-uninstallation so we can see the APT transactions.

Also, what model Pi?

Then it is all fine as I wrote before:

Logs are here: Update Error after Uninstall and Reboot
(that error dialog never appeared again though)

Model is Pi1B still.

That is not an APT Log, so we can’t see the APT transactions that have taken place.

Look at #3 in that thread

Start-Date: 2016-05-12  20:09:34
Purge: libflac8:armhf (1.3.0-3), armv6l-libafpclient-osmc:armhf (0.8.1-3), libfile-copy-recursive-perl:armhf (0.38-1), libbluray1:armhf (0.6.2-1), libkrb5-26-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), libhcrypto4-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), rbp1-image-4.4.6-3-osmc:armhf (3), libasn1-8-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), samba:armhf (4.2.10+dfsg-0+deb8u2), tdb-tools:armhf (1.3.6-0+deb8u1), libkdc2-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), samba-dsdb-modules:armhf (4.2.10+dfsg-0+deb8u2), libhdb9-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), libcurl3-gnutls:armhf (7.38.0-4+deb8u3), libroken18-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), update-inetd:armhf (4.43), libhx509-5-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), libheimbase1-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), libgssapi3-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), python-dnspython:armhf (1.12.0-1), libwind0-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), libheimntlm0-heimdal:armhf (1.6~rc2+dfsg-9+rpi1), apt-transport-https:armhf (
End-Date: 2016-05-12  20:11:29

It seems like you have been updating from very old version of OSMC based on the fact you have armv6l-libafpclient-osmc. This should be fine, but I can’t guarantee that you have upgraded properly as you appear to have run apt-get upgrade instead of dist-upgrade.

Does a fresh install without Samba server give you any freezes? If not – does installing Samba Server bring the freezes back?

[quote=“sam_nazarko, post:7, topic:16811”]
Does a fresh install without Samba server give you any freezes
[/quote] No


Both answered already here in #4 in the quoted post from the old thread …

Please stop referring back to the old thread! We are attempting to get the relevant info in one place so we are not wasting time digging through irrelevant and unhelpful info!

That’s why i did quote it here. So I am not wasting time writing it all over again. Still you have it in this place here.

So you have say you have done a clean install that doesn’t freeze but freezes after installing samba server onto it? Can you provide a debug log (grab-logs -A from that install?


Unfortunatly no, because I flashed back my backup after testing. I can do it all over again, but that would take a while. But I doubt the logs will be different from the one I already posted, after updating to the test build,as it is exactly the same problem.

I also have this problem…

Files are in SMB server

While my new RPI 3 is freezing only in Tv Shows section, my old one RP2 B+ works just fine.

I don’t think it matters wether the files are available through the server though. I did not setup the share on my fresh installation, just installed samba.

It was just additional info, as we don’t have a concrete knowledge of why samba is affecting OSMC.

Also, forgot to say:
I tried all from the beginning without installing samba in the first place but it didn’t change anything.

FWIW, although it wasn’t so much discussed, my guess is that the problem still lies on the JPEG decoding. Because if I include in my video library folders that does not contain any images(e.g. banner) it will not freeze. Continuing in this topic, it is indeed weird that my RPI 2 B+ does not freeze while my new RPI 3 does.

One more thing: Searched a little bit on google; Seems that TheTVDB is using progressive images right(although they say normal ones are still in cache). Wouldn’t this be an issue while using their service on the PI? Should I search for another service as substitute?

Then you have a completely different issue (see post 12) and should be creating your own thread…

Same issue here, graphics not loading when browsing files and when I open a mkv to play than the picture hangs. I SSH to my machine and reboot the pi, that helps for some time.
Since sometime in April I have this problem.
Only difference: I did not installed Samba server until yesterday. Yesterday I have this installed and the problem is still the same.
I think you should not look for it in the Samba server angle, but
rather in the SMB fix / patch that in late April / early May has been
patched (ie the samba client).
Whether the JPEG decoding is the problem, which would also have been possible.

Strange that the other topic is closed. I think you realize not quite how big this problem is and how many people suffer from it.
I have kept me aloof in another topic, but this is just closed has prompted me to react.
To prevent contamination of the forum it is perhaps an idea to add a poll where people can indicate that they also have the problem. Maybe that shows how many people actually have this problem.

Sorry to pollute this topic, but I just had to report it here.
As it seems now there will be no solution within short time. I am very happy with osmc, but I would not continue to use it this way. So please, please, fix it.

@ActionA; you write above this post that it is a completely different issue, Sorry, but they seem too much alike. This should be just the same.

The problem here is that this specific poster has started a thread about Samba server breaking thumbnail generation, and two people have replied saying that the Samba server uninstallation doesn’t for them, but thumbnail generation is broken for them. Therefore you’re saying that you have similar symptoms, but perhaps not the same cause, and you’re denying the original poster a chance to have his problem resolved.

If we knew what the problem was, we would have fixed it. But we don’t. Ideally, if your issues differ to that of OPs, you should provide logs in a separate thread. You should also let us know which versions worked, which of the test builds you have tried, dmesg when the device freezes etc. Otherwise, what we effectively have above is just another ‘+1’ post…

We understand there’s a problem, but +1s and ‘me toos’ are absolutely no use in resolving the issue.

1 Like

Update: now it happened with uninstalled smb server too. So this is not the cause (didnt expect it from what i have read here so far anyway) but seems just to improve chances that it may happen a lot.

So one can say, these symptoms many reported here really ARE related.