Time Capsule Connection

Apologies if this has already been brought up but I just (finally) received the Vero 4K+ and am currently trying to set it up with my Time Capsule. Unfortunately, I seem to be having issues connecting to it via SMB. Tried multiple methods:

  • via Kodi interface, adding the share as smb://[username}:[password]@[time capsule IP]/Data (note - this works perfectly on my MacBook). Get Error 2 - Cannot connect to share
  • also via Kodi interface, adding it through the network location wizard (the dialog where you indicate the sort of connection, IP, shared folder, etc)
  • the mount script offered here at SMB with Libreelec 8.2 and TimeCapsule not working - General Support - LibreELEC Forum - which used to work on my previous box using LibreELEC

When attempting the SMB connection via the Mac, any username combination works as long as the main password is correct.

Any advice would be greatly appreciated! It’s the last step to getting this fully set up properly…

Change the SMB version to SMBv1 under Settings -> Services.

That was a speedy reply, thanks! Afraid I’m still getting Error 2: Share Not Available…

Suggest to do some investigation from the command line.
Install smbclient sudo apt-get install smbclient
Execute smbclient -L <IP of timecapsule> -U <User on timecapsule> and report the output

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Getting the following:

Server does not support EXTENDED_SECURITY but 'client use spnego = yes and ‘client ntlmv2 auth = yes’
session setup failed: NT_STATUS_ACCESS_DENIED

Try to add the following three lines to either .smb/smb.conf or .kodi/.smb/smb.conf

client max protocol = NT1
client use spnego = no
client NTLMv2 auth = no

Than reboot and try again from Kodi

Tried that, still the same error. And to add to that, checked the .kodi/.smb/smb.conf (there’s no .smb/smb.conf on my box it seems) both after the reboot and the attempt, the three additional lines dissappear after trying to add the Time Capsule.

Try going to settings/service settings/smb client and set the maximum protocol version to none,
I remember having to do this for my original Vero 4K to get SMB working

Didn’t help either…

Are you trying to browse for the capsule, or add it manually?

Add manually. Although have tried browsing and got empty output there (presumably because of the password set on the capsule).

Hi,

I think these maybe the right settings, but may not be in the right place. try:

mv .smb/smb.conf .smb/smb.conf.old
nano .kodi/.smb/user.conf

update with the above suggested by fzinken and reboot.

Thanks Tom.

See File sharing with a NAS, media server, windows share or other device which may help

Looks like what @Tom_Doyle suggested there actually did the trick! Since I didn’t actually have a .smb folder in my home directory, I just created a user.conf file in .kodi/.smb/ with the three settings and now adding the Time Capsule using the manual path entry works!

Thanks all for the help, really appreciated.

1 Like

Taking this one step further, I’m now looking into setting this up as a fstab for a more stable connection as suggested by @sam_nazarko’s link to the wiki. Is it somehow possible to replicate the previously mentioned protocol/spnego/NTLM auth commands in that? Because following the instructions as is leads to the ‘no such device’ error…

Hi,

Have you tried adding:

vers=1.0

To the fstab entry.

Thanks Tom.

Yes I have, same thing - ‘no such device’ and when browsing to the mount point in the GUI I get ‘path not found or invalid’

Hi,

Please post your fstab.

Thanks Tom.

//192.168.1.18/Data /mnt/TimeCapsule cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=(hidden),password=(hidden),uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=1.0 0 0

Login and password to Time Capsule obviously hidden but it’s only letters/numbers and no special characters

My fstab line is nearly identical to yours, but instead of vers=1.0, I have sec=ntlm.

1 Like