Tivo Slide Remote with OSMC (Raspberry Pi 3)

Hi there,

I’m sorry if this is a repeat but I’ve searched here with both the built in feature and web search site tools, and found nothing of use.

I’m trying to use a Tivo Slide remote with OSMC and having no success in figuring it out. I followed the directions here: http://kodi.wiki/view/TiVo_Slide to no avail. On my Pi running LibreElec and Kodi it works fine but when I switch chips and run OSMC the green light on the dongle just stays on and nothing works. I can’t figure out what to do next.

I’m running the newest release of OSMC as of last night (I think it was marked February-2 or something like that in the list).

thank you!

Did you test LibreELEC Jarvis, or also Krypton?
There are known issues with some remotes on Krypton

I believe it may have been Jarvis, I’ll have to check, I only did the install a couple of days ago, but I see at the moment Krypton is only in Beta so likely I picked Jarvis. I can try going to Jarvis on OSMC as well and see if that helps.

So last night I tried the Beta of LibreElec Krypton and it works just fine with the Tivo Slide. So I’m back to believing it’s something not setup right in OSMC. Has anyone seen this combo work or am I just banging my head against the wall?

Did the remote ever work in OSMC?
Did you try a Jarvis (pre February image)?

That would certainly give some clues as to where we should be looking.

I haven’t only had time to try one last night, will report back when I have time to try a pre-feb image. Just built the system this week so I’ve only tried that OSMC image. Mainly what I was asking is, is this expected to work? I did a bunch of searching and can’t find any reference to anyone using this remote.

Have any luck getting it to work? I’m having the same problem with OSMC, though it works fine on my other setup using OpenELEC.

Just as a follow up: https://paste.osmc.tv/foqibovayu Had the same issue on Jarvis w/OSMC. But fine on Open & Libre ELEC.
Thanks

Nope, just gave up, it mostly works with LibreElec so I just gave up on OSMC and use LibreElec isntead.

That’s a shame. With some full debug logs we could have got this working.

As long as you’re happy with LE, use that.

If you want to tell me how to get logs I’ll give it a shot, but no one seemed to answer my questions (i.e. should is it expected to work) or asked me for any specific logs, I was happy to help but, still need a working system so I went to the path where things work.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/