TL-WN823N not working

Hi guys,
this is my first post and while I’ve seen a lot of threads on here about wifi adapters I can’t work out if I should be using a powered USB hub.

I’ve got a Pi 2 and a 2amp charger, only other usb device is a bluetooth connector for keyboard. Updated to latest version.

I don’t know how to diagnose the problem but from reading the forum it seems like this adaptor should be supported out of the box?!

I have a very cheap and rubbish wifi adaptor that works but is very slow. This is exactly the same experience I had with openelec installed before OSMC.

Would appreciate any help you can provide.
Cheers,
Andy

People need the ID of your stick to help you. So post the URL that comes out of dmesg | paste-log

TP-Link TL-WN823N is supported out of the box - I have one myself and find it the best of the four adaptors I have for OSMC.

Have you tried enabling the max_usb_current option in Pi config in My OSMC and rebooting ? I think it’s a fairly power hungry adaptor and I always have that setting enabled so it’s possible it doesn’t work without it.

Also please provide the log that fzinken asked for - this will help us see whether a driver is loading.

Apologies in really new to all this, how do I get to the menu where I can call up that log? Is it a command to be entered somewhere?

Yes I’ve tried the Max USB option with no success

An easier way would be to use the built in log uploader - go to My OSMC then Log uploader.

Thank you, I’ve uploaded the whole log, hope this is correct.

This link: both wifi adaptors attached

and this one: had to save to sd card as non working TL-WN823N attached on it’s own

I have a similar problem, my adapter is detected (TP link TL-WN8323N), will list my WIFI SSID on WPA2, and even claims to connect, but I cannot then SSH into the pi or even ping it’s IP.

ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter

I have tried connecting the adapter directly to the pi (a model 1 B+) and through a powered hub.

I am using the latest image. I spoke to SamNazarko - he suggested it was not a driver issue.

This might be an excuse to buy yet another pi! I already have 3!

Sounds very different to my problem pal, I’m getting nothing!

Hi, was there anything in the logs you could help me with?

Are you sure thats a TP-Link TL-WN823N ? (I assume 8323N is a typo) because the device ID does not match the one I have. Here is yours from your log:

usb 1-1.3: New USB device found, idVendor=0bda, idProduct=0179

Here is mine:

usb 1-1.4: New USB device found, idVendor=0bda, idProduct=8178

Completely different device. It doesn’t look like yours has a driver loading currently.

and that’s definitely the tplink one plugged in rather than the unbranded wifi adaptor?

If so, could my adaptor be a fake? It came with only chinese instructions.
Thanks for your help

Does it look exactly like this ?

http://www.tp-link.com/en/products/details/cat-11_TL-WN823N.html

No, I ordered this one http://www.gearbest.com/networking-communication/pp_47273.html

It doesn’t have the WPS button but I think the link you posted must be an updated version as one or two on the net look the same as mine

hmm, might just buy a new one and try again

Possibly a counterfeit - I bought mine in a store in the UK not online, and mine looks exactly like the link I posted.

If it’s not a counterfeit it could be a revision using a different chipset. It’s not unheard of for a manufacturer to release a new version of an adaptor with the exact same model number on the box but in fine print it might say it is revision 2. Often this different revision has a totally different wireless chipset inside which needs different Linux drivers, which can make recommending wireless adaptors based on their advertised model number problematic…

However if you can’t find one that looks like yours on the actual TP website, then I’d guess counterfeit/clone.

ok so mine looks exactly like: http://www.amazon.co.uk/dp/B00LMZRN70
but the packaging says that it’s a 823N. So confusing!!

I’ve just ordered one with the WPS button so will see how we get on with that.

What does it say on the metal part of the USB plug ? Mine has the model number engraved there.

As far as I can tell some search on the Internet there are 2 Versions
of this Dongel, v1 chip is ‘rtl8188cus’ and v2 chip ‘rtl8188eu’

Are there any sucess there?

Doesn’t sound right - my adaptor uses the rtl8192cu driver, not either of those.

My bad mistaken it with the TL-WN725N