TMDB scraping not working

Hi,
I have some problems with my Vero 4K+.
Yesterday I added some movies but they do not show up in the library.
I’m posting this issue here, because I connected the same hard drive to my windows laptop and Kodi found the movies without any problems. Only the version on my Vero does not find the movies and even if I try to search for them after adding the folders to content movies, I get a message that there are no information found. The naming of the files and folders is perfectly right.
Does anyone experience something like that or have any idea how to solve this?
I tried it several times since yesterday and it works on the laptop so I can rule out database problems at TMDB.

I would love to try to reinstall the scraper but it seems I can’t even delete it?

First make sure that settings>media>video>use video tags is NOT enabled. Second are you using nfo files and is your laptop setup to use the same scraper settings. You didn’t provide debug logs or extensive details here so without more info it is hard to point you in the right direction.

1 Like

Hi,
Thank you so much. It was the video tags setting.
I’m very sure I did not enable that and I never had problems scraping movies until yesterday. Was that part of an update or something?
Now it works fine. Thanks for the help.

I’m very sure It did not enable itself. It has been there for many years and has never been enabled by default, which is a good thing since it doesn’t work as intended. An OSMC update will not change any of your Kodi settings outside of exceptional circumstances.

Your welcome, glad it was an easy fix.

Funny thing because I’ve had my Vero 4K+ up and running for a long time and I just recently had the same issue despite having not changed settings in ages and it turned out to be the video tag setting which I didn’t know even existed.
Either an update inadvertently caused it or maybe my children found their way to that setting an enabled it but didn’t change any other settings.
@MikkaT do others in your household have access to your Vero?
I’m inclined to think that my children did it.
I like how there’s a description of what settings do at the bottom of the screen.
On some settings it is very detailed (see System>Audio>Output configuration) but on this option it’s pretty lacking.
It just says, “If mp4 or mkv files have tags, use this for library metadata”.
This should probably be updated with a warning or disclaimer of sorts like, “Enabling this feature will prevent your library from getting information from online scrappers. Enabling this option is not recommended for most users. Users looking to use offline methods may want to use this feature or nfo files.”

It is a bit more complicated than that. If there is no tags for it to read then the setting doesn’t do anything. If there is a tag then it depends on what it is if it will cause an issue or not. The problem is that it doesn’t try to clean the information before scraping it like it does when it reads a file name so “extra” information found in a tag (like an uploader name) gets included as part of the search to the scraping site and fails.

Also this is not a replacement for local metadata. It is an override of sorts for file name matching. I don’t have a clue what the use case for this would be or why someone spent the time adding it to Kodi.

@sam_nazarko can we just hide this broken setting? I already checked it and this works…

<advancedsettings>
	<myvideos>
		<usetags>false</usetags>
	</myvideos>
</advancedsettings>