Today's update killed my WMC remote

Things have been going well with OSMC on my Rpi2 up until today.

I have a Windows Media Center remote (RC-6) and it worked right out of the gate with OSMC. However, today’s update killed it.

Any ideas what might have changed with this update, and where to begin looking?



You could start by providing full debug logs, otherwise we can only guess, as you haven’t even said what type of receiver you are using for your remote.

Same remote, same problem. Have tried every different remote profile, but all either don’t work or duplicate keypresses now. IR receiver came with WMC remote.

Thanks for your response DBMandrake.

What a profoundly strange coincidence.

I did the update using the remote (never had a problem with it leading up to this moment). After the update was complete the remote had stopped working altogether. I noticed that the receiver light hadn’t been blinking when pressing a remote button, so I swapped out the batteries just to be sure. With the new batteries, the remote started working.

Pretty sure God is effing with me at this point.


Have your tried rebooting ? Uncontrolled repeats may be a sign that eventlircd stopped running during the update for some reason, which would give those symptoms, as repeat filtering is done by eventlircd. A reboot should fix that.

If not please provide full debug logs.

So changing the remote profile in the remotes section does have an effect on your remote ? There is a known issue with the RC6 profile which can cause duplicate key presses with some remotes - it is basically caused by the fact that the profile has multiple similar remotes in the same profile with some button code overlap.

The solution is to locate the correct profile for your remote inside that conf file and copy and paste it to a new custom lirc conf file, then select that.

This was an issue with the Xbox 360 profile for example, which is why I split it out to a separate profile as it was always giving me two repeats every time I pressed a button.

If this works for you, let us know which remote section you used and the name of your remote and we can add a separate profile for it for future releases.

I’ve discovered and fixed a bug that can cause issues with unwanted remote repeats.

The issue was that we were not guaranteeing that eventlircd was always started before Kodi, so depending on what else was going on during bootup, Kodi would sometimes start first. When this happens Kodi directly grabs the input devices, so they no longer pass through eventlircd’s repeat filter, thus unwanted repeats occur.

This has been fixed in the following commit and will be released in a future update:

For anyone that wants to test this fix early it is a very easy change to make. Simply edit the statup service for eventlircd:

sudo nano /lib/systemd/system/eventlircd.service

You will see a file that starts with the following lines:

Description = eventlircd remote support
After =

Immediately after the After line add the following line:

Before = mediacenter.service

Then save the file and reboot. If this fixes your remote repeat problems please let us know. :smile:

Tried it, but does not solve the repeat problem :worried:

I have tried this fix but this doesn’t appear to fix the problem either. I have also tried splitting the profile in to a separate config file and that doesn’t work either.

I have tried OpenElec 5.08 and the problem is gone.
That is a shame, because I like some parts of OSMC better than OpenElec.
But OpenElec for me seems a bit more stable :expressionless:

Considering that you’ve not supplied any debug logs or much in the way of information other than “it doesn’t work”, I don’t see what we could possibly do to fix your problem ?

There are literally hundreds (probably thousands) of different remote controls out there so it is impossible for us to test all of them, so without some help from users to troubleshoot issues there will be remotes that don’t work properly in OSMC.

If we don’t know what the problem is we can’t fix it.

I have send the logs (and links) of a much more anoying problem of the august version to this forum. It is about the micro-drop outs of music (playbacked via the library). Becuase I am still waiting for a response about this problem, I thought not to upload just another set of logs (and also because there are no errors in the logs). The drop-out bug is the real reason I switched to openElec; the solution to this repeat of key-press bug is something I noticed after switching.
I will try to do some more testing and send you the logs as soon as I can find the time, because I appreciate the work you guys are doing.

I am still getting the problem with a standard Microsoft RC6 remote. What information can I send through to help? I’ve tried with the September update but still the problem persists.

Can you try running ‘irw’ via SSH, to see if the buttons you press are logged ?

Hi, I tried this, below is the screenshot of the irw output

I pressed the ‘right’ key once, and then the ‘left’ key once

Hope this helps

edit: this relates to the repeat problem

There seem to be duplicate events being sent to eventlircd.

You can see an additional KEY_RIGHT being sent after KEY_RIGHT_UP. Here is what I see when I do the same test. (On an OSMC remote on a Vero, but same principles apply)

osmc@vero:~$ irw
6a 0 KEY_RIGHT linux-input-layer
6a 1 KEY_RIGHT linux-input-layer
6a 2 KEY_RIGHT linux-input-layer
6a 0 KEY_RIGHT_UP linux-input-layer
69 0 KEY_LEFT linux-input-layer
69 1 KEY_LEFT linux-input-layer
69 2 KEY_LEFT linux-input-layer
69 0 KEY_LEFT_UP linux-input-layer

Notice there is only one key up event for both button presses. Can you try the following for me. Install a package called ir-keytable:

sudo apt-get update && sudo apt-get install ir-keytable

Then run the following command:

sudo ir-keytable

And post the output of this command here so we can see it. Then try running:

sudo ir-keytable -p lirc

Let us know if this eliminates the duplicate button presses. (It will only take effect until a reboot)