Total Noob SSH Question


I have installed OSMC on my Pi 3B and have got onto the command line to change the OSMC password.
On the Pi itself, I can log into the OSMC account with my new password quite happily, but when I try to SSH on with Putty, I get “Access Denied”
Logging onto correct IP address.
User : osmc
Port 22

Any suggestions ?

Latest version of Putty?

I believe so - when I do an “About” in Putty, it says version 0.70 and when I go to the website, it says that’s the latest
Thanks for the incredibly swift response by the way

Do you get access denied before login request? User/password question?

Is SSH enabled on the Pi? I think during the install there is an option to disable it if it’s not needed. MyOSMC can probably help you re-enable it.

No - I get “login as:” to which I respond “osmc”.
Then I get “’s password:” - I give it the new password and I type the new password I have set.
Response is “Access denied” at that point

Are there any symbols which are prohibited in the password ?

ARGH - ignore me
I just accidentally typed my password in a visible field and I find that the keyboard mapping is different - “d’oh !”

Sorry to ask the obvious, but did you check with CAPSlock on/off? And the same password works with local login?

Not to my knowledge are there any restrictions in what you can use in your password.

Great that it’s solved

Thank you so much for your help - it was a case of sheer stupidity on my part.
I did warn you it was a noob question lol

To my mind, password fields should be visible by default. Especially in a domestic environment.

1 Like