Touch only works on the upper left corner using a usb egalax-like touchpanel

Hello, I have been digging how fast OSMC boots on my raspberry pi 2 (13 seconds tops!) and I have been able to get the HDMI to work with little effort, but the issue I have been running into is how to get the touchscreen panel to work properly with kodi.

lsusb shows for this device:

Bus 005 Device 002: ID 0eef:0005 D-WAV Scientific Co., Ltd. 

Oddly enough, my output doesn’t say egalax anywhere, even though I almost always see the word “egalax” included in the outputs others have come up with when I google “D-WAV Scientific Co., Ltd”.

I do have a factory raspbian image where the touch DOES work that I downloaded from here. I tried spotpear’s drivers downloaded from here, but no go.

I bought this screen from eBay

I was able to get osmc to work with a 3.2" spotpear SPI tft display when osmc was raspbmc. The display worked, but I was unable to get the touchscreen to work properly with kodi/xbmc. What was weird was that touch worked with X applications, but not kodi/xbmc.

As stated in the beginning, I love OSMC because it does boot so darn fast, and I want a fast OS for a car media player I am building, and this would be a winner if I could get touch to work seamlessly. I also want to use it because it’s based on a minimal raspbian setup (plus I’m used to raspbian/debian/ubuntu’s command structure).

Another mention: I was able to get touch working simply by copying the modules and kernel from the factory image and replacing the ones in OSMC with those.

The issue I am having now is that the touch only works in the upper left corner within kodi and is not calibrated (as a matter of fact it has the same symptoms I ran into when I was using the 3.2" spotpear), which from what I am seeing in this and other forums is a common problem that I have no idea how to fix.

Does anyone know how to fix this??

It looks as if someone has worked out a fix - is this link amongst those you have tried?

I haven’t tried this one yet. I’ll give it a go then report back. Thank you.

I just got through trying the link but I haven’t been able to get it to work because [code] cd /scripts/uinput-mapper

./ /dev/input/event0 -D | ./ configs/ [/code]

does not run and I get this

FAIL MUCH? Failed to open uinput Traceback (most recent call last): File "./", line 59, in <module> d = UInputDevice() File "/scripts/uinput-mapper/uinputmapper/", line 194, in __init__ raise OSError OSError Exception TypeError: 'argument must be an int, or have a fileno() method.' in <bound method UInputDevice.__del__ of <uinputmapper.cinput.UInputDevice object at 0xb6a0b250>> ignored , and when I touch the display I get this Traceback (most recent call last): File "./", line 111, in <module> sys.stdout.flush() IOError: [Errno 32] Broken pipe

and thus I am not able to run the uimapper service, which depends on those scripts working. I have also been trying to contact the admin of the tutorial for some help, but no responses so far.

I have seen references to this tutorial the internet over but still have not been able to get touch to work with kodi.

Why is this such a widespread problem that NOBODY has a solution for?? They really need to fix this!