Touchscreen only works in top left corner

Hello I am running OSMC on a Raspberry Pi 2. I have a 14" touchscreen (http://www.chalk-elec.com/?page_id=1280#!/14-HDMI-interface-LCD-with-capacitive-touchscreen/p/36248806/category=3094861) The touch screen only accepts input in the top left hand corner. I can run the pointer all over the screen but when the pointer is in the bottom right hand corner my finger is just a little up and left of the center of the screen. How can I fix this?

1 Like

Have you tested the screen using any other software?

Sounds like touch resolution doesn’t match the video resolution displayed. How the touch portion of the screen is calibrated is not dependent on OSMC, contact the screen manufacturer.

I got a second sd card and loaded Raspbian and it works fine under that. Loaded Kodi on that os and the same thing happens.

Hi,

I have the same problem with my HANNS-G 23 HT231 Touchscreen. Only the top left corner works!

Are there any settings to make in any config-file?

thanks for help

Same problem here using Acer FT220HQL. Is there some way to recalibrate touch screen settings?

By the way, before anyone asks, the touch screen works perfectly using Windows and OpenElec.

Same problem here 15.6" HDMI interface LCD with capacitive touchscreen from http://www.chalk-elec.com

http://www.chalk-elec.com/?page_id=1283#!/15-6-HDMI-interface-LCD-with-capacitive-touchscreen/p/38127425/category=3094861

runnig perfect using windows please fix it

It seems that this might be too esoteric a problem for anyone to be actively trying to solve it, but if there is a hint that could be offered about the location of the touchscreen configuration files, it would really be helpful…

Really hoping for a solution here. Same issue, raspbian wheezy touch works fine on my touchscreen but not with osmc

This is a skin issue, most likely. Not all skins support mouse control (and are therefore not touch screen-click friendly). Try changing your skin to Transparency. It works fine on my Chalkboard Electronics 10" capacitive touchscreen in OSMC. Also, make sure you update screen firmware. This is necessary on the Chalk-Elec screens.

I am having the same issue. I have tried using several different skins and am currently trying to update the firmware as we speak. Also has anyone tried contacting the manufacturer on this issue?

This is not a skin issue. I have tested the problem out using a number of skins, including Transparency, and the results are similar, with the touch calibration being way off. It is likely that we just need to be able to calibrate the touch screen, but since I have no clue now OSMC handles this, I have been unable to do so.

Hey guys,

I’ve been having this issue for a long time, just like you. But I finally found a solution for it and thought to share it with you.
I have created a tutorial for the solution: http://arendwierks.blogspot.nl/p/touchscreen-fix-raspberry-pi-xbmc-kodi.html
I hope it will help you!

Best regards,
Arend