Transcoding with OMX is freezed

After updated to Krypton, the HW transcoding with openMax is freezed suddenly.

I transfer the MpegTS videos to OSMC (RPi) and transcode them into h264mp4 with the hardware decoder/encoder on Raspberry PI.
Before update to Krypton, that process worked fine, but currently the trascoding is freezed on the way.
I tried ffmpeg with omx-rpi and gstreamer with gst-omx but both results the same.
I have 2 RPi2s, one is OSMC and another is Raspbian on which transcoding works fine.

I watched the CPU usage with “top” cmd during the transcoding,
ffmpeg (or gstreamer) was at the top usage at the starting of transcode.
Several mins later, ffmpeg dropped from list suddenly, but its process is remained with no progress.
However, short videos such as 30sec or 3min can be transcoded without freezing.

Is there any way to keep transcoding until the end of longer videos?
Many thanks in advance for your help.

Mabve a stupid question, but do you have sufficient space on your media?

Can you share your command lines than I can test on my systems (I have one with December version and one up to date)

In case of ffmpeg,

/usr/local/bin/ffmpeg -y -i test.ts -c:v h264_omx -b:v 2000k -acodec copy test.mp4

In case of gstreamer,

filesrc location=test.ts
! progressreport
! tsdemux name=demuxer demuxer.
! queue
! aacparse
! avdec_aac
! audioresample
! audioconvert dithering=0
! voaacenc bitrate=192000
! mux. mp4mux name=mux
! filesink location=test.mp4 demuxer.
! queue
! mpegvideoparse
! omxmpeg2videodec
! videoconvert
! omxh264enc target-bitrate=5120000 control-rate=variable
! video/x-h264,stream-format=byte-stream,profile=high
! h264parse
! mux.

I use the same scripts before and after the OSMC update.

Currently, 40% of my 64G SD was used.
The TS videos I tried are 500MB(5mins), 1.2GB(15mins) and 3.6GB(30mins).

I guess the remained disk space is enough to transcode each of them.