Transmission connection failed

#1

I am trying to setup Transmission. I downloaded the app through the MyOSMC app store. I was able to connect to the Transmission Web interface and add a torrent. I changed the download location to a harddrive attached to the Vero. I set it to a folder that was not created (thinking it would be created after setting this location in the Tranmission web interface). Download started but I got the Permissions Denied message.
At that point I thought it was because the download destination folder had not been created. So I created it by accessing my HD through SMB.

Before or after this (I forgot) I change my OSMC password ussing terminal on my MacBook to connect through ssh with my Vero and change the password with the command passwd

When I tried to access the Transmission Web client again I got the connection failed message (server not responding). Checking the status of Transmission on the Vero in the services part of MyOSMC it had the status of enabled (where it previously said running). After a reboot it did say running again. And I was able to connect to the Transmission Web interface. After trying again to download the download folder was set to OSMC/download and I got the message there was not enough space. I removed the torrent, changed the download location and tried again. At that point again the Permissions Denied message showed and/or simultaneously the connection failed.
Checking services again in MyOSMC I see Tranmission status again is Enabled in stead of running.

What am I doing wrong?

I simply want to add a torrent through the Tranmission web interface and set the download location to a folder on the exFat HD connected to the USB hub attached to the Vero.

#2

Hi,

I think transmission is failing because its unable to write to the folder on the external drive. The folder you have created needs to be owned by osmc. To do this you need use chown, the command will be something like this:

sudo chown osmc:osmc /media/*harddrive*/*folder-created-for-transmission*/

Thanks Tom.

#3

Thanks Tom for the info. I am trying to understand the file structures on OSMC.
When I look in SMB I see my download folder on the HD has the following path: smb://192.168.178.16/500/downloads

should the command for me be

> sudo chown osmc:osmc /media/500/downloads/

Or

sudo chown osmc:osmc /500/downloads/

And can someone tell me why the Transmission app goes from the status ‘running’ to ‘enabled’? And how can I get it back to ‘running’ without a reboot?

Can I keep rebooting without a problem by the way?

edit 1

I think I have found what I did wrong.

I used the wrong path to my download folder

I had home/500/downloads where it had to be media/500/downloads

Before I figured this out I used the command:
sudo chown osmc:osmc /media/500/downloads/

I am not sure if that did anything for me. I did not get a response in ssh

edit 2

Am I correct when I state that you cannot access the files on the HD when at the same time tranmission is downloading to that HD? As a bottleneck is created or something like that.

#4

Hi,

ExFat could be causing a bottleneck, is the hard drive going to connected to windows PC? Or are you just leaveing the drive connected to the vero4k and accessing via smb? If its the latter, I would advise formatting as ext4.

Thanks Tom.

#5

Hi…I am having the same problem, it just started happening recently, I tried checking on the “randomize port on launch box” but it only works for a minute or so, then the error comes back again and again, any other options here?

#6

Hi,

Are you getting the Permissions Denied error message? If not please start a new topic, as Transmission would be crashing for a different reason.

Thanks Tom.

#7

Drive is connected to Vero. While writing to drive by means of transmission I cannot read drive in Vero (watching movie) and access through SMB is extremely slow.
This weekend I will have a new HD that I will format to ext4 and test again.

1 Like