Transmission Deamon failed

Hi everyone,

I am new to the forum. Very charmed about the osmc project.

I have encountered the following issue. While I boot, the first line states that the transmission Deamon failed to start.
I followed a guide online to install transmission a few weeks ago on RC2. Everything seems to be working though. I can access transmission without any problems.

Anyway to get rid of this error?

btw: I have it installed on a rpi2

Hi @guids please attach some logs or screen caps of the error that you see on the screen if possible… ;-).

How did you install transmission through the app store?

Goodmorning @HarryL

So I looked inside the log, I think this is the culprit:

Jun 02 10:24:39 osmc transmission-daemon[285]: [2015-06-02 10:24:39.201 CEST] Couldn't read "/var/lib/transmission-daemon/.config/transmission-daemon/settings.json": Permission denied
Jun 02 10:24:39 osmc transmission-daemon[285]: [2015-06-02 10:24:39.201 CEST] transmission-daemon Error loading config file -- exiting. (daemon.c:519)
Jun 02 10:24:39 osmc systemd[1]: transmission-daemon.service: main process exited, code=exited, status=255/n/a
Jun 02 10:24:39 osmc systemd[1]: Failed to start Transmission BitTorrent Daemon.
Jun 02 10:24:39 osmc systemd[1]: Unit transmission-daemon.service entered failed state.

I am a novice to OSMC and Linux. Apparently I have to fix permissions. On initial install of OSMC I had to manually give permission to every folder which SickRage/Transmission/Couchpotato use. Not sure if that was the correct way of doing it. And maybe I have missed something?

I have used this guide http://www.htpcguides.com/install-transmission-raspberry-pi-latest-version-raspbian/.

btw: I have it installed on a rpi2

Try changing everything that referenced user pi to user osmc. Including the chown command too.

I entered the chown commands again. using the appropriate osmc:osmc.
The error remains unfortunately .

What about the other references to user pi? Because that user does not exist in OSMC by default.

Otherwise, there are several transmission install/config threads here that are specific to OSMC that would likely be more relevant than a tutorial that is specifically for Raspbian. Probably something simple you are missing here.

You probably need to chown -R osmc.osmc /var/lib/transmission-daemon

I think the path is the problem , i have my settings file placed ind “/etc/transmission-daemon/settings.json”

In your earlier post the log file complained about permission denied in /var/lib/transmission-daemon/

sorry for my late post.

I did a complete reinstall of the system, and followed the guide from htpcguides.
Now everything works. I might have messed up the settings before