Transmission download speed below 100kBps

Hi guys,

I am using OSMC for 3 months now and I love it!
But lately I have experienced some unwanted behavior from the transmission client: My download speed does not go above 90-100 kBps any more. This has happened since one of the last 2-3 updates, I don’t remember exactly. If I download the same torrent using uTorrent from my PC remotely to the RPI, it works fine.
My current setup is:

  • RPI3 with wlan connection
  • Downloading to an external HDD, WD MyPassport 1TB, new, mounted as ntfs.
  • I am from Romania, so my internet speed is not a problem.
  • uname -a outputs:
    4.14.26-2-osmc #1 SMP PREEMPT Thu Mar 15 18:20:26 UTC 2018 armv7l GNU/Linux
  • I am using Kodi UI, if it matters
  • I haven’t changed anything in the settings.json. I have no speed limit set.

Anyone experienced this?
Any ideas?

Thank you in advance!

If the drive is only going to be used with OSMC, then I would recommend reformatting the drive as ext4. If you need access from Windows/Mac then ExFAT should be Ok. NTFS is slow on linux.

I coult try that, but why this has happened suddently a few weeks ago? It ised to work perfect on the same setup. I could download with 2MB/s.

From experience, when something starts slowing down, usually it is the network.

Well, you did say the drive was new…

As @Smurphy said, next step would be to check out your network performance. iperf3 is your friend.

The default settings.json is 100 for download. you could adjust it and then reload transmission.

Try to rule out the wifi and test a wired connection. Also: at which rate do you transfer large files to/from the Pi via FTP?

Just to make sure, you’re using transmission from OSMC’s app store, right?

So guys, thanks for your fast replies, but let me clarify again some topics:

  • My HDD and internet is working fine, because I am uploading from my network with high speeds. Also now from my phone I am uploading via FTP with 2MB/s.
  • The download limit is by default false in settings.json. I have also played with that and also with the numbers and no result.
  • Yes, I am using transmission from osmc app store

The problem is somewhere else.
As I said , 2 months ago worked fine!

You need to do some testing to narrow things down. You can use iperf3 to test network speeds, and dd to test drive speed. Once we know how the local network (from the Pi) performs, and how the drive performs we can maybe narrow down the problem.

The first major thing I would suggest you try (if you can) would be use wired instead of WiFi network.

To test the drive speed, run this from a command line on the Pi

dd if=/dev/zero of=test.file bs=1M count=5K status=progress

test.file should be on your external NTFS drive, so something like this: /mnt/my_external_drive/test.file

It will create a 5GB file (that can be removed) and show you the speed of the drive.

1 Like

Just to eliminate all doubts for all you guys,I have run the dd command and the write speeds are good. Here is the output:

5355077632 bytes (5.4 GB, 5.0 GiB) copied, 216.058 s, 24.8 MB/s
5120+0 records in
5120+0 records out
5368709120 bytes (5.4 GB, 5.0 GiB) copied, 216.58 s, 24.8 MB/s

Also I have tested a download with wget:
Saving to: ‘OSMC_TGT_rbp1_20180319.img.gz’

OSMC_TGT_rbp1_20180319.img.gz 75%[============================================OSMC_TGT_rbp1_20180319.img.gz 75%[============================================OSMC_TGT_rbp1_20180319.img.gz 75%[============================================OSMC_TGT_rbp1_201803 100%[======================>] 172.72M 682KB/s in 3m 40s

2018-03-28 21:27:37 (803 KB/s) - ‘OSMC_TGT_rbp1_20180319.img.gz’ saved


As a next step, I’d recommend you try downloading something that we know will be well seeded, such as an Ubuntu or Linux Mint ISO. Running it for a few minutes should be enough to see how it performs.

Don’t forget the possibility that it’s your ISP throttling bittorrent traffic.

have you added any new cpu intesive addons in kodi? My transmission have no issuses, had to limit download to 2,5 megabyte/s. The other thing might be large files with lots of small chunks.

You never mentioned your inbound and outbound speed, if you hit your outbound limit your download will be affected.

I have tried. And there are slow speeds, max 60 kB/s

I have downloaded the torrent from here:

About ISP traffic, I am not sure, my uTorrent works perfect from the same network.
Also I have played with the port setting on transmission, and no success there.

Maybe you have overshot your monthly allocated bandwidth and your ISP is throttling your Internet connection?

Just a suggestion: Try speedtest-clito test your internet speed from the OSMC device

sudo apt-get install speedtest-cli

speedtest-cli uses the infrastructure of afaik.

1 Like

I dont have any limit:)

Well - apparently there is something limiting you.
When you talk about slow transmission - what are you transmitting? Movies? Updates?
Net Neutrality has an impact on these things lately. I can tell, I have Fiber to the Home with a 1Gbps Download and a 200Mbps upload speed. I rarely access a site/resource I can download with full speed.

Only things where I reach 500Mbps are when downloading a Game via Steam.
Downloading the last Star Citizen Game gives me up to 800Mbps download speed. That - is awesome :slight_smile:
But movies? no. The Streaming is limited to the playback speed. Hence not required, except when I download something on my tablet - like Amazone Prime/Netflix - for watching in the airplane later on.
But here, the WiFi limits the download speed (~120Mbps) when I’m not too far from the AP.

PS: I have the entire House cabled with Cat6, and all my routing equipment is able to handle that speed, also the NAS is able to handle 2Gbps (Too many Kids in my house).

Guys, it seems that i discovered the problem, it was my eyes!

In settings.json, somehow I had the :

alt-speed-down : 50,
alt-speed-enabled : true

So I set it to false and now I have 2-3 MB/sec download speed again!
I did not see that.
I had checked every setting in the json file for limiting the download, but that. I had:

speed-limit-down-enabled : false,
speed-limit-up-enabled : false

Everything but that alt-speed-enabled setting…

Thank you all for your help, was good that you helped me elimiate some cases.

Have a nice day, OSMC rocks!

1 Like