Transmission in app store

Please excuse my ignorance, but installing Transmission from OSMC
app store, what is supposed to be installed? Transmission daemon?
Transmission Kodi add on? an OSMC-specific interface to Transmission? something else?

I thought it was daemon and add on. But if that were the case, then the transmission from app store does not work.
But I am unsure if is really that or that I should be going about installing transmission daemon manually or something. (defect or lack of feature)

We’re quite aware as evidenced in the linked thread in my post above.

Installing manually works fine.

Same here :frowning:
Installed manually

I have not done it manually. I am holding in case team likes a log or something. If I install it manually I won’t be trying with the store again. And I can wait, so lets see if there are further changes in the store that require some testing.

It should be working well now


Ignore comment. Sorry.

hi Guys!

On rpi2 i’m also not able to install transmission. I select install, then click on “Apply” but it just goes back to the main OSMC settings and nothing happens.

Any idea what could possibly go wrong?

Here is my log:

1 Like

Just a quick update guys, i tried to install it from command line, but when i run sudo apt-get update i got a dpkg related error. I followed the instructions to run:
sudo dpkg --configure -a
after that i was able to run the sudo apt-get update command as well. Just quickly went back to osmc to try whether it will install Transmission now and it worked.