Transmission Not Working

So I decided after three years to rebuild my OSMC system (on a Pi 3) from scratch over the holidays. I just figured it was about time. The only thing I can’t get working is Transmission and all of the discussions seem a bit old (point to different configuration locations and files).

Running a pretty plain OSMC install. Pi 3, OSMC, one external USB drive mounted from fstab. OpenPyn added (following HowTo post here). Log Viewer and Transmission (0.7.6) added from repository (9.9.11). When I try to go to the Transmission interface from Add-Ons I see the normal screen flash by quickly, then I get “Could not connect to Transmission - Open settings dialog?” If I open the settings dialog all looks normal (port, user, etc.). Trying to connect to the web interface gets me a “connection refused” (I can connect to the Kodi web interface just fine).

Running “systemctl status transmission” gets “unit transmission.service could not be found” (same trying “transmission-daemon” instead).

This used to work (before I started a clean install) so I know I’m missing some simple setting or installation. My memory seems to say a version update, but repository says I’m up to date.

Any thoughts?

Transmission can be installed from the app store in the MyOSMC add-on. The log you uploaded was only the Kodi log so i’m not sure what exactly you expected us to see regarding Transmission itself.

Ahh, I think I missed the distinction of App Store vs. AddOn.

However, when I install from App Store I get

Error Installing:armV7-transmission-app-osmc(2.9.4-1) Please report this to the OSMC Forum

If you had manually installed it with apt then I would expect issues. I don’t know if the app store is doing more than just installing. I’m sure someone will come along at some point today that can answer that. I would guess you could just try uninstalling it with apt and try the app store again. I think you might need to also make sure transmission is not trying to use the same port as Kodi’s web gui.

Thanks for pointing me to the App Store, I had missed the distinction between actually installing Transmission and just the front-end provided by the AddOn.

Not sure why it wouldn’t install the first time from the App Store, this is a very clean OSMC install and I have been trying not to do anything outside the actual skin controls. Nevertheless I ran an apt purge transmission and then installed from App Store and all worked fine.

Thanks again for getting my head pointed in the right direction.

1 Like