Transmission Permission error + VPN setup

After getting a VPN-service for our home computers and therafter trying to getting it to run on the Raspberry Pi B+ (OSMC 2017.12-1) i’ve run into a number of problems.

I searched the forums and the web for guides on the VPN and i think i have it up and running as it should. But when I try to download anything via Transmission I get errors after 2-3 minutes of downloading.

“Unable to save resume file: Permission denied”

I resume the download and the same error appears after 2-3 minutes.

*More searching on the forums and the web…

I found alot of information on different issues with permissions and so on. I mucked about with that for 2 days now and nothing seems to work or getting me closer to a solution.

  • Could my VPN cause this issues? And where can i find information on how to fix it?
  • How/where can i check if the permissions for Tranmission/users is the issue?

Any help or tips to get everything up and running as before?

I’m a beginner when it comes to this kind of stuff but i’m fairly competent with computers in general and somewhat decent in figuring out stuff as i go along. But this time i am lost.

I tried to upload the logs but I get this error message:

Exception Details:

Traceback (most recent call last):
File “/usr/bin/grab-logs”, line 792, in dispatch_logs
raise ValueError(‘Upload Returned Empty String’)
ValueError: Upload Returned Empty String

Failed to upload log files, copying to /boot instead. (Unable to verify)


Where are you trying to download the torrents to? Is on the pi, usb drive or network path?

I’m assuming you are using openvpn Its not very clear from you post. If you stop openvpn, do you get the same error from grab-logs?

Thanks Tom.

Trying to download to external harddrive powered by it’s own adapter.

Yes, OpenVPN.
Sorry I missed writing that in my first post.

Yea, when i stopped OpenVPN i could grab logs

You might have better luck with transmission if you use the version from the OSMC app-store.

It also looks like your VPN might not be running correctly. Do you know why you have two VPN tunnels: tun0 and tun1?

Alright, I will look into that.

Absolutely no idea why there would be 2 VPN tunnels. Good/bad? Must have been in one of the guides i went through in my efforts in getting the VPN to work.


I think this is where the issue is coming in with uploading the logs when connected to vpn.

Which vpn provider are you using? I’ll see If I can help with the setup.

As dilthedog advises I would remove transmission and install the one from the store.

Thanks Tom.

I’m using OVPN.

Will try a fresh install of Transmission from the OSMC app-store.

There’s stuff in the log related to PIA.

Good move. Remove the old stuff first. :wink:

Yes, thats not right. I went through the guides i followed and in one of them there was references to settings/config for PIA. Must have missed that.
But i’m using OVPN and it’s working great on two other computers here at home.


I think this is the guide you should be following:

Thanks Tom.

Hi there,

I think I may be able to help.

You just need to change the permissions on the directory where you saving the files.

To do so, ssh into the Pi, and use the command “sudo chmod 777” followed by the path to the directory.

I hope this helps,

I tried that guide first of all, and for some reason it didn’t work correctly.

Will try tonight to start over and remove Transmission and hopefully restore most of the changes i’ve made.

Thank you (and everyone else) for all the help. I’m gonna try do everything from the start and hopefully it will work by tonight.

Alrighty then…

Tried to remove Tranmission, no success. “Package ‘transmission’ is not installed, so not removed”.

Tried to access the App Store. Not working… no response.



sudo apt-get remove transmission-daemon
sudo apt-get purge transmission-daemon

Then try installing from the store again.

Thanks Tom.

That worked, thanks!

But i still have problems accessing the App Store. Any ideas?

And now my wireless connection decided to stop working. “Status: No internet”.

My god. I feel like it would be easier to do a complete reset and start all the over from the beginning with a fresh installation of OSMC.

Is there a function for restoring OSMC to “default” settings and start over all from scratch?


Enable debugging log and try accessing the osmc and upload logs.

To be honest this may be the best way forward at this point. Just download the osmc installer again and install last version of osmc on the sd card.

Thanks Tom.

Yea, that seems to be the best option right now. Maybe also upgrading from my B+ to a 3+ finally :slight_smile: Been thinking about that for a few months now.

Thanks for all your help anyway.