Transmission speed throttling in OSMC

Hi there!

I finished setting up my Rpi 3 B+ with OSMC. I got everything working great except transmission. I’ve tried with multiple torrents varying in size from different trackers. The same thing happens. It connects to peers, speed jumps to 2-3 MB/s, stays there for a few seconds, then it throttles down to speeds in the kB/s range, sometimes to 0. Stays there a few seconds, jumps back up to 3 MB/s. It makes downloading anything a hassle.

I’ve checked my transmission settings, the speed is not limited, no maximum speed, no nothing. I tried wired connection&wireless, does the same thing. I tried operating it on a single port(no random port) and opened that port on my router. Did not influence it one bit. Nothing changes. I am downloading to a USB Kingston DataTraveler DT106/64GB stick that was formatted to Ext4.

My internet connection is really good, I have no limitations from my ISP and any torrent downoalds without any issues on my PC.

Any ideas? Thank you for your attention.


Are you using a vpn?

Thanks Tom.

Hi. No VPN whatsoever.


Wired or wifi.

is the DataTraveler DT106 connected to a usb powered hub? If it isn’t this would be the next I would try.

Thanks Tom.

Wired right now, tried wi-fi also and the same issue occurs. The stick is directly connected to the Raspberry’s USB port. Wouldn’t using a hub slow things down even more? Directly seems like the better choice, no? Thanks

No, a good powered hub will not slow things down. Directly can be a problem as the stick may be drawing to much power.

1 Like

Ah, ok. Hadn’t thought about the power draw… But wouldn’t the hub be connected to the Rpi and in the end draw the same amount of power? I’m sorry if this is a stupid question

Not a powered hub. It has a separate power supply.


Oh, ok, I see. Didn’t even know those were a thing. Ok, might try one of those. I just tried downloading directly to the OS SD card. The same thing happens…

You can test the speed of the stick like this:

dd if=/dev/zero of=/path/to/stick/test.file count=10M status=progress

That will simulate copying a 5GB file to the drive. Don’t forget to remove test.file when you are done.

Will give that test a go. I also tried with a separate Sandisk 16gb stick. Same thing…

Yeah, it’s definitely a power problem. Tried transferring files through SAMBA from my PC. The same thing happens with the speed. Thank you for pointing me in the right direction!

Did you try the dd test that I suggested? That will help narrow down the problem. The test you did via SMB still could be another problem, like networking.


Please confirm are you using an official pi powersupply?

Also it may have developed a fault, it may worth trying another one.

Thanks Tom.

Will be trying this today, for now I am locked out of OSMC while trying to set up UFW and now I can’t SSH. Can’t even access the console locally with a keyboard. I tried Exit - Wait for splashscreen - Hit Esc. But no splashscreen appears, it just boots directly into OSMC after showing a black screen for 30 sec. So think I’ll have to format and reinstall…

Yep, I am using an offical pi power supply. I will be buying a new raspberry soon so I’ll see if the problem persists with that one also.

Hi again. I’m sorry for the delay, but I finally did the test. It started at 50MB/s and went down to about 12-13 MB/s. Here are my results:

5368709120 bytes (5.4 GB, 5.0 GiB) copied, 404.577 s, 13.3 MB/s

What do you think?