Transmission torrent speeds slow

Hey, I’ve been using my Vero 4k as a torrenting box but I keep getting slow download speed when using transmission.

I have a fast 200/20 mbit line and all other devices have high download speeds. I’ve tested it by downloading the same torrent on my PC and I had maximum speeds, while transmission on vero only had like 1/10 of the speed… it was a very well seeded torrent too.

The port 51413 is opened since I use upnp on my mikrotik router. I’ve restarted both my router and vero. My vero has wired connection and I’ve run speedtest-cli and it shows max speed.

I’ve also double checked and I don’t have alternative mode turned on or download limits setup.

I’m using an external HDD for incomplete and complete directory, it’s NTFS and does use up quite some CPU, around 50-70% of CPU is constantly being used by transmission and NTFS mount. I doubt formatting to ext4 would help though.

Anyone have any ideas what to do? Kinda sucks that I keep getting shitty download speeds on my good connection…

NTFS is going to be your bottleneck here. The implementation is entirely in user space so there is a lot of overhead.

ext4 is the best option. exFAT is OK if you must switch the drive between machines.

You can format the drive trivially with mkfs.ext4 /dev/path/to/device.


Hmm, is there a way to mkfs.ext4 without losing current data? I really don’t have any device where I can backup 1TB of data lol

Unfortunately not.

If it wasn’t ‘torrented’ content; I’d let you use our storage platform over the weekend. A cloud service may do the trick.

What you could do, is shrink the NTFS partition, create an ext4 partition, copy things over, then delete the NTFS partition and resize. This can be done with the command line, but something likw a GParted LiveCD on your PC will make things easier.


I’ve now formatted my device as ext4 and the cpu usage has been noticably reduced to around 5-10% compared to 50-70% before. That’s ok, but it hasn’t improved my torrent speed situation at all. I am lost, I don’t have a clue what to do and it’s super frustrating.

I’d suggest that, rather than relying on UPnP, you manually forward port 51413 to the Vero4K.

Also, are you using a VPN?

Hmm, might try and port forward it manually on my Mikrotik… if only it wasn’t such a nightmare doing that on it lol.

No, not using VPN.