Tried calibrating screen, failure

I tried to calibrate my screen on my rpi2, but with horrible results. I can’t revert them to defaults. What are the default values?

What do you mean when you say you tried calibrating your screen. No one has any idea what you have done based on the lack of information you’ve provided.

You should try and disable overscan on your TV instead

S

If you’ve completely messed up your GUI settings the best method is to delete your guisettings.xml. (afterwards you will need to configure your main settings again)

From ssh:

sudo systemctl stop mediacenter
rm -f /home/osmc/.kodi/userdata/guisettings.xml
sudo systemctl start mediacenter

I agree with sam’s comment too - if you think you need to use the screen calibration feature, you don’t. You really need to find a way to disable overscan on your TV. (Modern TV’s usually let you do this on a per-input basis)

The screen calibration feature should be used as an absolute last resort if there is no way possible to set the TV correctly, because apart from it being the “wrong” way to fix the problem, it causes a significant loss of image quality due to the fact that you are scaling the image down in size and the TV is then blowing it back up. Both steps will soften/blur the image.

Thanks! Doing this fixed my problems :).

If others arrive at this thread with the same overscan issues i.e. it doesn’t fit the screen and you can’t turn off overscan on your TV then add these entries to your config.txt rather than ‘calibrate’ within kodi.

disable_overscan=0
overscan_left=24
overscan_right=24
overscan_top=24
overscan_bottom=24

The Overscan left,right etc values will be different so a bit of fiddling needs to be done but it works perfectly on my Panasonic Plasma TV now.

Further info here config.txt - Raspberry Pi Documentation although ignore the hdmi_safe bits you just need what I mentioned above :smile: