Tried doing update

Tried update getting this message
Error installing ssh-app-osmc

Can you upload logs via My OSMC?

I take it you got to
Log uploader
Upload selected logs now
As I’ve done that

Then get this
URL:https://paste.osmc.tv/ititelsges

Dont think last one worked

Think this one is ok

URL:https://paste.osmc.tv/yumeyikico

What is the output of
ls -lah /etc/ssh/sshd_config.distributed

I don’t know what that is

Connect to the command line (see below) and run that command and let us know what is says. There seems to be a problem with your config files.
Alternatively you could try to uninstall and reinstall ssh-app.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Just tried reinstalling ssh app

Operations successfully completed

OK, then I assume update should also work now without error

That seems ok

But get this after reboot

Add-on couldn’t be loaded
An unknown error has occurred

Would need a debug enabled log for that.

URL:https://paste.osmc.tv/jopazumewa

These are not looking good:

ERROR: SQL: [MyVideos116.db] SQLite error SQLITE_IOERR_READ (disk I/O error)
2019-08-07 15:57:59.565 T:3939496672   DEBUG: CAddonCallbacksAddon - GetAddonSetting - add-on 'Enigma2 Client' requests setting '__addonpath__'
2019-08-07 15:57:59.565 T:3939496672   ERROR: Create - Error creating X����/��

You could try a full reinstall but suggest to then keep monitoring it after the reinstall

Been getting them error messages since first week of owning

How to do a full reinstall?

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

While maybe not as efficient as a reinstall you could first try with a clean Kodi setup

sudo systemctl stop mediacenter
mv .kodi .kodi.save
sudo systemctl start mediacenter

And I use putty for that?

Yes. It looks like the issue might just be with your Kodi setup, and therefore a complete system reinstall may not be necessary.

yes

Did that
After reboot no error messages
So I presume for now all is well